summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/zeroconf
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest2
-rw-r--r--dev-python/zeroconf/zeroconf-0.29.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index c9727a19752d..836ba8c5e495 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,5 @@
DIST python-zeroconf-0.28.8.gh.tar.gz 62107 BLAKE2B 94b910be9f95f8b50bfcd5fca102663713234d40a0cf90c5b94b2ab4e85ffd7363747a0fee2f7a72a3bfb74faa1cab703dfb8bfe3cef80a0495efe2c81d0c2af SHA512 ba599fdd44ecdf3da71ee2a155a47e6cf91c8f4fe3efac428f6e99feda052019423a8a3e775d6cc4624697fbfcbe207829a41ad76105082fe62e81eead2f7a34
+DIST python-zeroconf-0.29.0.gh.tar.gz 62466 BLAKE2B 430a9f4d4460d66166a2484862a8dd3af65f3cfad0e25557648abf26ebe88a7ae581934273db270ff30fa4d714b32a822448b22fd7a95e9e382b68ffae9b66b4 SHA512 a084da17cda264b531e7f58975d30ae0b5adb98f33ca78d1e865e1450dc42ad2bca69bc319c268f7977e70e082ae713142a57f97a9f050486c47b50698002590
EBUILD zeroconf-0.28.8.ebuild 871 BLAKE2B 772550912df25c87816e8b876f67d30202412eea4cdc90e2d78145ae1f56569f86fc4b6d5b90f2994f843b9ed705eab59f9d0797811fbf522fe46ceaaba4eb59 SHA512 5fd62d1e49db89ad884b0484251e20940685ee1af8c26480caecff6fdf9ec10ad03d67fb92caabfcf6e79214de34b1a4709f318d297f0904823d87973f58aca4
+EBUILD zeroconf-0.29.0.ebuild 1021 BLAKE2B b2af14b40649768c7d1b1964cab62a385b24a30d0dbb1b3e7fdb1ce9ffdcfe1993adb78245d107d1b13f166767b20e8450df518617970789b85c6ffac6c48fb5 SHA512 38e27588b7ef5483b128708db7c086e50e854545f4f4f6c9d26df21751401ab45225a2f348fe90231156de6be5476527cf0e5ea6f17521c28f7b1b225d3e2f7a
MISC metadata.xml 412 BLAKE2B 70dd13f9065885850c7c24da7e1a0825a1537e452213847e00d8af9977818d6bfcfda9c8f9e0d0b2241550a95d186432e0072762a1b77e65b66441812b29651a SHA512 28bafc2919fa66c0f1e532798ac40c537a53c18e781590881116440886d09f5511425f2cddee912e3fc63ef92ee1a9c4da0f7f79cb44dab6e5f51d62202de844
diff --git a/dev-python/zeroconf/zeroconf-0.29.0.ebuild b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
new file mode 100644
index 000000000000..fc762bc9256f
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ zeroconf/test.py::Framework::test_launch_and_close
+ zeroconf/test.py::Framework::test_launch_and_close_v4_v6
+ zeroconf/test.py::Framework::test_launch_and_close_v6_only
+ zeroconf/test.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect } zeroconf/test.py
+}