summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf/zeroconf-0.59.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
commitf20a854a6189579b2cc296900c479d9b6b5b595e (patch)
tree310fb68782e96ae228c8ffe97ae3b2859a7e4a17 /dev-python/zeroconf/zeroconf-0.59.0.ebuild
parentb7e514e2dc987a8b3e10ea8ea3d6e1d197eeb355 (diff)
gentoo auto-resync : 02:05:2023 - 05:22:02
Diffstat (limited to 'dev-python/zeroconf/zeroconf-0.59.0.ebuild')
-rw-r--r--dev-python/zeroconf/zeroconf-0.59.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/zeroconf/zeroconf-0.59.0.ebuild b/dev-python/zeroconf/zeroconf-0.59.0.ebuild
new file mode 100644
index 000000000000..29801ba74dbb
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.59.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}