summaryrefslogtreecommitdiff
path: root/dev-python/zc-buildout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/zc-buildout
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/zc-buildout')
-rw-r--r--dev-python/zc-buildout/Manifest3
-rw-r--r--dev-python/zc-buildout/metadata.xml22
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.5.3-r1.ebuild56
3 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/zc-buildout/Manifest b/dev-python/zc-buildout/Manifest
deleted file mode 100644
index f4f2a79e0344..000000000000
--- a/dev-python/zc-buildout/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST zc.buildout-2.5.3.tar.gz 305163 BLAKE2B 83ef87a8b61e109498117704e4055ac533bec9be9a5d2ceb0a573808f776ca6fe607ef542ef7e7486759612da9041162a44bba19692e8ffc65c4f3cb23f99760 SHA512 a4d4becac815531cd180795372ce5896d1fdab8606fff492502ef1f59d6d1ddd8427bb00ea96d36ec284a18b17b9273d8b94a405ebe410bae7e9a6e47a8dfad7
-EBUILD zc-buildout-2.5.3-r1.ebuild 1242 BLAKE2B 1a4d670d84422707f6b44f7e8f0b60a252a0afdf642be1c203f8ec51aeef590104647ae6d208e4a054a82de04b39aa571924923b7edf7d93ac728cee8aa28290 SHA512 ee723d3fcb11042f99537615b0f81912d55ae4b080d01ae41e970944c658dda4bb6f0c8e2ef19a73de017b09f99d3c0938c1928bdcd1e957a2d0ebc82e9792a3
-MISC metadata.xml 1414 BLAKE2B 0a15f64e7b7abac30ebf4264fb998845069e3288f9dd7886cf916c2dd40f85204e00bf3a2f6712b05b00b1139e195c9e08906527df8992fea32aac8ef43842c1 SHA512 a5940bca5da541fbd21a7b1d7c2dd3db0d4415d336974ec1c638ad003e117480a000e780435cf254ee66d61a9f7552a13eaad2209223c5f190c4a9c96603a4e7
diff --git a/dev-python/zc-buildout/metadata.xml b/dev-python/zc-buildout/metadata.xml
deleted file mode 100644
index 57406ae085b3..000000000000
--- a/dev-python/zc-buildout/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">Buildout is a system for managing development buildouts. While often identified as a Zope project,
-and indeed licensed under the ZPL by Zope creator Jim Fulton, buildout is useful for configurations
-beyond Zope, and even, in rare cases, a few that have nothing to do with Python.
-The Buildout project provides support for creating applications, especially Python applications. It
-provides tools for assembling applications from multiple parts, Python or otherwise. An application
-may actually contain multiple programs, processes, and configuration settings.
-The word .buildout. refers to a description of a set of parts and the software to create and assemble
-them. It is often used informally to refer to an installed system based on a buildout definition. For
-example, if we are creating an application named .Foo., then .the Foo buildout. is the collection of
-configuration and application-specific software that allows an instance of the application to be
-created. We may refer to such an instance of the application informally as .a Foo buildout..</longdescription>
- <upstream>
- <remote-id type="pypi">zc.buildout</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/zc-buildout/zc-buildout-2.5.3-r1.ebuild b/dev-python/zc-buildout/zc-buildout-2.5.3-r1.ebuild
deleted file mode 100644
index 0a2e6c846174..000000000000
--- a/dev-python/zc-buildout/zc-buildout-2.5.3-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="System for managing development buildouts"
-HOMEPAGE="https://pypi.org/project/zc.buildout/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-
-DOCS=( README.rst doc/tutorial.txt )
-
-# Prevent incorrect installation of data file
-python_prepare_all() {
- sed -e '/^ include_package_data/d' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if python_is_python3; then
- ewarn "Tests are broken for ${EPYTHON}, skipping"
- continue
- fi
-
- distutils_install_for_testing
- "${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- python_moduleinto zc
- python_domodule src/zc/__init__.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}