summaryrefslogtreecommitdiff
path: root/dev-python/youtube-search-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/youtube-search-python
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/youtube-search-python')
-rw-r--r--dev-python/youtube-search-python/Manifest3
-rw-r--r--dev-python/youtube-search-python/metadata.xml13
-rw-r--r--dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/youtube-search-python/Manifest b/dev-python/youtube-search-python/Manifest
new file mode 100644
index 000000000000..b115ca9dcb62
--- /dev/null
+++ b/dev-python/youtube-search-python/Manifest
@@ -0,0 +1,3 @@
+DIST youtube-search-python-1.6.3.tar.gz 115934 BLAKE2B 1151a29da0d66206424a88a2ac3839269f11d970b4a829f9d33ede4ef7ffec39c6762bfe138edd5da9c57308444021be93054c34cbc71e12a031a8d798d94975 SHA512 16d0dfbc95387bb3ccac9224e53ea087cdfa41d1330abd96fc3ad0136af227359fc2d8409a2eca81ae2fe9790efdb86a42e409748ba1a49c595df2629216e331
+EBUILD youtube-search-python-1.6.3.ebuild 535 BLAKE2B 878846d79f99acecef667a7942eec2304f87529f97c7cfe250682ee37add76eeb5ccb2285ca50ec9cef97eb53ef1cb3503a1c38f61d8d8673a61f64d2ea55b43 SHA512 c43886ce2d34f39ae3c41a80d94f1823cc77efd550ece662e5408f1f8804ee1bde59ccfe63c12f4ad30b26fd4e54b710fd2a05eeeb2e41e8f33d78cdea1aff4f
+MISC metadata.xml 441 BLAKE2B 886bea7098ee9959e832ebff56473617460048fba908c5273e76b40a6452d6a2bb637365985eeffd937b1ff5793168b0336971c609d3ef6eebd1decffa4f8471 SHA512 3c53fe9194609683298cd17417ab00bf0767bcbba364511e491b26b251dd634d902ef5fc13d114e03b0e7860666d0ff20f2018640ad84fe581e0c853d2ee9db0
diff --git a/dev-python/youtube-search-python/metadata.xml b/dev-python/youtube-search-python/metadata.xml
new file mode 100644
index 000000000000..bc129c31ebbe
--- /dev/null
+++ b/dev-python/youtube-search-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/alexmercerind/youtube-search-python/issues/</bugs-to>
+ <remote-id type="github">alexmercerind/youtube-search-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild b/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild
new file mode 100644
index 000000000000..923cfa88f17f
--- /dev/null
+++ b/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get YouTube video information using link WITHOUT YouTube Data API v3"
+HOMEPAGE="https://github.com/alexmercerind/youtube-search-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+"