summaryrefslogtreecommitdiff
path: root/dev-python/yattag/yattag-1.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 10:32:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 10:32:42 +0100
commit5d1fadfaf82053fc45d6120cb990be1ffb05fc8d (patch)
tree8d36fff15d7c7ebb6834f324a115e82f24cdbaf2 /dev-python/yattag/yattag-1.15.2.ebuild
parent5684fb5128e63f45e3c4a58a58ba9b2a124a2a28 (diff)
gentoo auto-resync : 28:10:2023 - 10:32:42
Diffstat (limited to 'dev-python/yattag/yattag-1.15.2.ebuild')
-rw-r--r--dev-python/yattag/yattag-1.15.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/yattag/yattag-1.15.2.ebuild b/dev-python/yattag/yattag-1.15.2.ebuild
new file mode 100644
index 000000000000..ab3b6eecf552
--- /dev/null
+++ b/dev-python/yattag/yattag-1.15.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library to generate HTML or XML in a readable, concise and pythonic way"
+HOMEPAGE="
+ https://www.yattag.org/
+ https://github.com/leforestier/yattag/
+ https://pypi.org/project/yattag/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ eunittest
+}