summaryrefslogtreecommitdiff
path: root/dev-python/yarl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-02 21:19:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-02 21:19:42 +0100
commitca45ec83b5d77af14152011046f506005a8a71aa (patch)
tree5f5316694d864e9f8ab24c0ee020c54e6e25cceb /dev-python/yarl
parent5b49b81b5ef191481800fac695706d35262f8781 (diff)
gentoo auto-resync : 02:08:2022 - 21:19:42
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest2
-rw-r--r--dev-python/yarl/yarl-1.8.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index f83c99c28f8d..dbf2bfff8c36 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,3 +1,5 @@
DIST yarl-1.7.2.gh.tar.gz 108115 BLAKE2B 7bd212b652a77ac29fde4c6565c48c4067f2a24db6bbf735107f3dfa5ee8b6ad2e5a5c3c6206e8dc7692e4cfd5c975d4304dd93280087574bddd73a337417c52 SHA512 bf69c5758f523259757ff84a8737e28931f46311f12f6e141329a5074d34a0cfb45795bf79cb7b78cb676ca7bc38042a2fbd946a5f41bf1d149ada50b88b31ae
+DIST yarl-1.8.1.gh.tar.gz 109912 BLAKE2B c7390b78abb5074dd29e96848a77fdb31f6224e99d2bcfd5a28a8bd08881f5ff82cf55b2f54c97324d005a0fb3823732a9ed6bd3f1d837e4ac2341b89e2adb30 SHA512 267523216832c2bc83d92a42e621ff519d427e20c1ee84ac657e13f696a2df2259c837486f192d87944f5ebb834beea60ace791eb4c9c632fd7e552eb5dadf1b
EBUILD yarl-1.7.2-r3.ebuild 910 BLAKE2B 68d8fc7b158dd40cb8dd08f9a2b39544b17ade53772f742ddf951d29dfcb55daee99bada90676a797d8ace257092842d72cd3cb3abfab2fe99203cbf6d4b0a88 SHA512 ecf4dcc5136ed7fa3c2a3c937d61466993cfef4e0408086a253340deabe8f46e9cfe56bfc8cdce8560cf12ba84d9904515ec4d783ed85d49ac04daf7ac01ba2e
+EBUILD yarl-1.8.1.ebuild 918 BLAKE2B 72373c54cf93ea0df89c030684cc0975fcc9aa6c508f10e19ef08dd4acd404477bc6cd2cfe02f6b334ddead19683f6416750eb9ecda206093a29b9d39253af4f SHA512 12460e120e522e3abb3355d0331e63ecc9c93a15e82219efde14c2afde343678e418987adc90d9e5a9ebe759ab9aa26d7918f58bf50a630651bf6433d07a9054
MISC metadata.xml 440 BLAKE2B 10fd0e37c9be76c5d1dd90b9fd1cb1e5161fc5a7d2b51bcb5658a8c187a67d5f9573241733c3f9570e9fb7767bf84b38a6f8b2c212596627bea4e1686b7eb41e SHA512 c9e340124ed93cb0d52a0ae5abd43c10528197893c3d5ab57a0eb7046ebae5b80119f7b033d6697110c4bc064c0a8581d904788f6969cb52a433064067898cbe
diff --git a/dev-python/yarl/yarl-1.8.1.ebuild b/dev-python/yarl/yarl-1.8.1.ebuild
new file mode 100644
index 000000000000..7ea5cc25c82f
--- /dev/null
+++ b/dev-python/yarl/yarl-1.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+SRC_URI="
+ https://github.com/aio-libs/yarl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_configure() {
+ > .install-cython || die
+ emake cythonize
+}
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}