summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/yarl/yarl-1.4.2.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/yarl/yarl-1.4.2.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.4.2.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/yarl/yarl-1.4.2.ebuild b/dev-python/yarl/yarl-1.4.2.ebuild
index 029aea2f92fe..6f51bcb5ac23 100644
--- a/dev-python/yarl/yarl-1.4.2.ebuild
+++ b/dev-python/yarl/yarl-1.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -13,15 +13,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/multidict-4.0[${PYTHON_USEDEP}]
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PN}-1.4.2-test-without-coverage.patch
@@ -29,7 +27,3 @@ PATCHES=(
# Upstream: https://github.com/aio-libs/yarl/issues/410
"${FILESDIR}"/${PN}-1.4.2-disable-broken-tests.patch
)
-
-python_test() {
- py.test -v tests || die "Tests fail with ${EPYTHON}"
-}