summaryrefslogtreecommitdiff
path: root/dev-python/yapsy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
commitda6a52f691ef980bab92d003d5df8f463c623af8 (patch)
tree4d89e0d5915f8a3f57c8f9c17420ba3f7b44b7b2 /dev-python/yapsy
parent80208fb578cf92cc308906660ca6d7860c6b2a1f (diff)
gentoo resync : 10.03.2018
Diffstat (limited to 'dev-python/yapsy')
-rw-r--r--dev-python/yapsy/Manifest2
-rw-r--r--dev-python/yapsy/files/yapsy-1.11.223-python36-tests.patch22
-rw-r--r--dev-python/yapsy/yapsy-1.11.223-r2.ebuild47
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/yapsy/Manifest b/dev-python/yapsy/Manifest
index 732986c80445..0584e4dffccb 100644
--- a/dev-python/yapsy/Manifest
+++ b/dev-python/yapsy/Manifest
@@ -1,3 +1,5 @@
+AUX yapsy-1.11.223-python36-tests.patch 919 BLAKE2B 51e27515c9e4a129a11aca1e9f37859e0e74386c499fd093e304a27e72d104733a66e643de5303e6ac18df6ad16b2de840025d255f062aa360e3ff18f94dae66 SHA512 aa345024f6afde87f9e3a64da87778f1bd620cd8490d1c564cf74f3a5821eb034d94cf5b464bf567725972122ba78a981cb2d120b3e0f35541a01ecd4f97170a
DIST Yapsy-1.11.223.tar.gz 80783 BLAKE2B 44f1224f66a35e3ff01d0fb0cf1e0c46fe7932d6fe2ddbaf1c7eed72b7324d8e9fba7be2d32cbec93f33a6d3779b17eb979af751778f672bbffc1119c912e30d SHA512 690d0ab78eafede5a75cf7b7bbcfce00b05c7b6f958980c3b67815bcaf848a8098b6e81afd1d95c5821fa4bb7affefab2cde208ff7c8ac7952615c8ddbafe305
EBUILD yapsy-1.11.223-r1.ebuild 924 BLAKE2B 15bd062e32f05e83d2093fc4ac7bf1ceb6ce57ed908b10856d02b28837145c00e1ac8ebc631dfdd16dc548803bacb5c92ede38d140354efdae5f27c18f49ad6f SHA512 fffec518a965ed7f01043f02ea42f50acac32893b453d53843f75ab7a55dd0ebec312de289314b6274f0f8fdebe88b0554a81a1d824202ee296747c90d97a80b
+EBUILD yapsy-1.11.223-r2.ebuild 984 BLAKE2B 1fdedcbb67a46392aaa7756833f62b2a23125ea78dec7ac09d8885f924a1a80e41f71bdc497f3522d97465830b7853c5587c2615415f944ba5541339ff19114f SHA512 9fff3834c8bbcfa09b5ecbe84276923fa887dcd07e23b6ea6a062fc64ca3d04e82331faf3e793461616793641aca68b5e2a11f60eeb4c8f6eb70cfd690c33629
MISC metadata.xml 423 BLAKE2B a30bb50714d2efa8d7bf299e53a3992ab24fd55ef2670fc7a15f25ed6fd864fd112940b0a202491307de2f74eb339292e32a475a7cbe89cf1dbd2ea4f6f47b8c SHA512 73e423d31a622b7b15bf672cdbada8378d069954acecdf6d729f05ca4297ef01016519adf362b322dced4694de829f079c80a17c836b5ee458b772a3c5fd36d8
diff --git a/dev-python/yapsy/files/yapsy-1.11.223-python36-tests.patch b/dev-python/yapsy/files/yapsy-1.11.223-python36-tests.patch
new file mode 100644
index 000000000000..55b6b00873ba
--- /dev/null
+++ b/dev-python/yapsy/files/yapsy-1.11.223-python36-tests.patch
@@ -0,0 +1,22 @@
+From b79ab28e430995cd64923bb93474b214bc38529b Mon Sep 17 00:00:00 2001
+From: Thibauld Nion <thibauld@tibonihoo.net>
+Date: Sun, 29 Jan 2017 18:31:06 +0100
+Subject: [PATCH] fix error on python 3.6
+
+---
+ test/test_ErrorInPlugin.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/test_ErrorInPlugin.py b/test/test_ErrorInPlugin.py
+index 171ce5d..9f22dcf 100644
+--- a/test/test_ErrorInPlugin.py
++++ b/test/test_ErrorInPlugin.py
+@@ -50,7 +50,7 @@ def errorMock(*args,**kwargs):
+ self.assertEqual(len(callback_infos),1)
+ self.assertTrue(isinstance(callback_infos[0].error,tuple))
+ self.assertEqual(loadedPlugins[0],callback_infos[0])
+- self.assertEqual(callback_infos[0].error[0],ImportError)
++ self.assertTrue(issubclass(callback_infos[0].error[0],ImportError))
+ # check that the getCategories works
+ self.assertEqual(len(spm.getCategories()),1)
+ sole_category = spm.getCategories()[0]
diff --git a/dev-python/yapsy/yapsy-1.11.223-r2.ebuild b/dev-python/yapsy/yapsy-1.11.223-r2.ebuild
new file mode 100644
index 000000000000..62cd725684e6
--- /dev/null
+++ b/dev-python/yapsy/yapsy-1.11.223-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="Yapsy-${PV}"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fat-free DIY Python plugin management toolkit"
+HOMEPAGE="http://yapsy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python36-tests.patch
+)
+
+python_prepare_all() {
+ # Disable erroneous test
+ sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
+ -i test/test_PluginFileLocator.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}