summaryrefslogtreecommitdiff
path: root/dev-python/yamlpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/yamlpath
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest2
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.4.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index d701cf1dd2c7..0d054c1cb711 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1,5 +1,7 @@
DIST yamlpath-3.6.1.tar.gz 214053 BLAKE2B 5c72ffc4e4307f1a3fea7a697782c432402acc1ee929de34a702188d51287fd7187b688354533163b7101dc17ed394f0e2681a1a194807f00762bf6c71387292 SHA512 8ef8e1931118ed881d52b6d7f589b1c671694c211cb1c988e7e6945b7ff5408163bd402f52c1815b453bf8ccc61e8b8ed5c19a00be076d8e76e0a037461a12e2
DIST yamlpath-3.6.3.gh.tar.gz 214734 BLAKE2B fd36d276831771c81272a2bb60a9fe7995c63f1026143925e34167ee397b56725ec9ba5d5afac2a85121512b8f8da3f988fd022dc2378ee80b91567f15d95c1a SHA512 b6c41b550339809e3a0bcbd7dca190956f06799303c1c12bb68eed567c56ccafd2acc2a8a6ab33fb03abde61b3de25673ee2d459f6d66e6782f9325212653ade
+DIST yamlpath-3.6.4.gh.tar.gz 216016 BLAKE2B fc6537b7c80ecfb9f69c646970e43935374bb105df007c123cf837eb1de6827ac2cc443294b69500c966ea6bc5d7f56498aec13340238c7660118f17cc6685e5 SHA512 eb1ac0d5861818f4f4b57b07f9fa7f758846982abbb3ac4ec58a1adaca8ec36deba1e21ce3e13916e74a946512f4d66e341a9d45392ef7133d0293e5fd6f66c9
EBUILD yamlpath-3.6.1.ebuild 1365 BLAKE2B 73ccdc94a1b063a65813333494f009b0514eb2fcc76a7e0c544007b5caeb9a7cb7f071fe1078cc891777dc48e3577a26697d0849eb377a904cc6ee84d602b46f SHA512 ec30e9533015048d698b7ccddbbf2d4228bfbf56e112a22a12209ad3d99d50e7ff50578b10bc7801fb4c90ddf2995bc6b0dfb0dc52ddde53a06df9fc811aea67
EBUILD yamlpath-3.6.3.ebuild 1152 BLAKE2B c17ad924d0b66cced0f5932ca62c08b425ee887a5f29d2f6d01abb0d816709487651057de63bc8dcc6146d9a91e26d18699d6ca62405c3e37816c2ac96fc2416 SHA512 17d457d9ab28505b6e6a254cdb358180e8ed931704071a9acb3e5dbdeccde24c19141a02ba2d0ea9cca49d47eb8a3bcc49d82c2f4a3d3ec8f16c292f45566a10
+EBUILD yamlpath-3.6.4.ebuild 1152 BLAKE2B c17ad924d0b66cced0f5932ca62c08b425ee887a5f29d2f6d01abb0d816709487651057de63bc8dcc6146d9a91e26d18699d6ca62405c3e37816c2ac96fc2416 SHA512 17d457d9ab28505b6e6a254cdb358180e8ed931704071a9acb3e5dbdeccde24c19141a02ba2d0ea9cca49d47eb8a3bcc49d82c2f4a3d3ec8f16c292f45566a10
MISC metadata.xml 563 BLAKE2B 5b63f4324ccc2685c7e11f4a75b105f9e97b860a983ffba37f1ae862082ce4654d0114ecde9fe7dc66e1c8121e607ade520e3f34192d2e85ebd538ff0631f355 SHA512 f50a3f78e2fa6d4f06fb1f52267202781d189942135112b45f17ed620025b87637925d3205f151573fee635b5f7b4d2ef1de5106223cd13d2f8e2963a31d29ac
diff --git a/dev-python/yamlpath/yamlpath-3.6.4.ebuild b/dev-python/yamlpath/yamlpath-3.6.4.ebuild
new file mode 100644
index 000000000000..aee7c4907046
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data."
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}