summaryrefslogtreecommitdiff
path: root/dev-python/yamlpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-python/yamlpath
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest3
-rw-r--r--dev-python/yamlpath/metadata.xml14
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.0.ebuild56
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
new file mode 100644
index 000000000000..fe2656666fa2
--- /dev/null
+++ b/dev-python/yamlpath/Manifest
@@ -0,0 +1,3 @@
+DIST yamlpath-3.6.0.tar.gz 214052 BLAKE2B 6b969a8c6e63f879e9c9f17f4542a48e55987835f99f10867577d93107813b684cfa0bf647f6d11b8ef8f02438e7e72f847eb0a29761a169950f8a5c6ee0ec5b SHA512 377cd281b4e7df251bbb298977c258e1a547ce4726ad321e5bf500242884049d3e052b83b83b72d477111fe121bd483d5122427498a5ebf784ab6d86d92d6ed6
+EBUILD yamlpath-3.6.0.ebuild 1365 BLAKE2B 98610b1c3ea596d0af58762f2d48cc4a5753651d9726cd3a483a974270a4d462113e28e981544f3f7a1dc5b1d562716396ff1f8657226041f5c19e670d727eee SHA512 203678520033600fe34d6ab5434881c7f5e4023fca0f261e944e852a1dc2c5a7098aafbe06ce278833b69e4a5e7aba4c096c7b5f8ebcadb3ab66b11666b66370
+MISC metadata.xml 562 BLAKE2B d2b091da12ffd474dd53c09dff56c07aef9f5c6395910315b346cba6762f1eb163b9f62d269e4de97d77fb388d4262a7b6baa0889344765f3fdbab7c86483c00 SHA512 e96c675721a9e538cd835dd07ce1fe949a5c3edd354c6f040d70c6a18f4179f44ff8d7ebdce600b800278d08823ef1ba90d5264e5e53190fb81aa698a5bafe95
diff --git a/dev-python/yamlpath/metadata.xml b/dev-python/yamlpath/metadata.xml
new file mode 100644
index 000000000000..096a53d7d984
--- /dev/null
+++ b/dev-python/yamlpath/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/wwkimball/yamlpath/issues</bugs-to>
+ <changelog>https://raw.githubusercontent.com/wwkimball/yamlpath/master/CHANGES</changelog>
+ <doc>https://github.com/wwkimball/yamlpath/wiki</doc>
+ <remote-id type="pypi">yamlpath</remote-id>
+ <remote-id type="github">wwkimball/yamlpath</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/yamlpath/yamlpath-3.6.0.ebuild b/dev-python/yamlpath/yamlpath-3.6.0.ebuild
new file mode 100644
index 000000000000..ac88b3e28ffc
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data."
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="https://github.com/wwkimball/yamlpath/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="test"
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ local sed_args
+
+ sed_args=(
+ -e 's|\("ruamel\.yaml\)[^"]*|\1|'
+ -e '/pytest-cov/d'
+ -e '/pytest-console-scripts/d'
+ )
+ sed "${sed_args[@]}" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}" py.test -v tests || die "Tests failed under ${EPYTHON}"
+}
+
+yamlpath_post_src_install() {
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}" || die
+}
+
+src_install() {
+ find "${WORKDIR}" -name tests -print0 | xargs -0 rm -rf || die
+ distutils-r1_src_install
+
+ python_foreach_impl yamlpath_post_src_install
+}