summaryrefslogtreecommitdiff
path: root/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild')
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
new file mode 100644
index 000000000000..da1a8cb891c4
--- /dev/null
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
+HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper https://pypi.org/project/xvfbwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-base/xorg-server[xvfb]"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}