summaryrefslogtreecommitdiff
path: root/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
commit0704956f7256f1f618cc5e03af2c1dbd0e83dbc5 (patch)
tree881671532c0c3c82ebd4523b6d6cbc8ace982aae /dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
parent21435953e16cda318a82334ddbadb3b5c36d9ea7 (diff)
gentoo resync : 16.01.2020
Diffstat (limited to 'dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild')
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
index 9c4b8f613007..49aebade00d5 100644
--- a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
inherit distutils-r1
@@ -12,14 +12,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="x11-base/xorg-server[xvfb]"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
-"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
python_test() {
"${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"