summaryrefslogtreecommitdiff
path: root/dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild')
-rw-r--r--dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild b/dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild
new file mode 100644
index 000000000000..6b3ba86d8c89
--- /dev/null
+++ b/dev-python/xstatic-jquery/xstatic-jquery-1.10.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="XStatic-jQuery"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XStatic jQuery package"
+HOMEPAGE="https://pypi.org/project/XStatic-jQuery"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/xstatic[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}