summaryrefslogtreecommitdiff
path: root/dev-python/xmltodict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/xmltodict
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/Manifest4
-rw-r--r--dev-python/xmltodict/xmltodict-0.11.0.ebuild6
-rw-r--r--dev-python/xmltodict/xmltodict-0.12.0.ebuild22
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-python/xmltodict/Manifest b/dev-python/xmltodict/Manifest
index f7a0cfdd71dc..d8968cbd655f 100644
--- a/dev-python/xmltodict/Manifest
+++ b/dev-python/xmltodict/Manifest
@@ -1,3 +1,5 @@
DIST xmltodict-0.11.0.tar.gz 26589 BLAKE2B 29498ac9c2f80828aa24d6cc4866aa6846fe10eb411a3e3617d85989c88628cc7c87ab80adb9ded492545fa2b4796a14b540479da75bfe464d1dfd811bbe1dc9 SHA512 d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295
-EBUILD xmltodict-0.11.0.ebuild 624 BLAKE2B 4eb074b835f0b5661c3d90e272b4868fc89b75259b2fe9b5bae55161d9b16c8fb564bcbdb3838f4f4643fe3661b23bae250e4ec5ff5cdac6f6e6121cb5534eb9 SHA512 65f5fcf925dc33aa5444723cc99d532d3d0f6b66a03b9befc448c78f9ed73376f807dd8fd910953f5fe182ab059e585a4385e0c13aff25941e14f23cdd70f47f
+DIST xmltodict-0.12.0.tar.gz 18481 BLAKE2B f7b7b71a6eaacc833a54369be38aa988b5c27845b19001c1d13e955df1f3a26c04dd2a1b45f0c0e704c4df6f4d380abdda7189944cc45b001eeef55405c43299 SHA512 1ec3de3ebd05adbe032ca569a71048e72097c0f5fc864b63f168d661f72d13d0981e6e62bb9ca2ffe925a3b2f7c2fb90a44177427d4bdf68137842342a9cd2c8
+EBUILD xmltodict-0.11.0.ebuild 631 BLAKE2B 38fe5006c99ae1b3bf0d3e4de2faaf580861746d2918efee552e9db447ab7ab4ccad90deb8cdb0a250eecac3363cab3635f71c0e0cd4a6b732018c7817e906d7 SHA512 bdbe2e3b26421a7bd3ce859bfebada8c6545a392ccd7120cd5aa6ceed015716d59d353bdc1dcd37782825378a5f2e94e2ef61c2acac37f49ff25efaa11a74437
+EBUILD xmltodict-0.12.0.ebuild 636 BLAKE2B c59f19c0203db19cfa8e9a2913a615079f12fb3263e3729c20456af5b200d4a85e8d10703a5dc9a764f047dc1e050ff95300e352232a501b9b1bedeaf23cfae7 SHA512 6c15532961439e12d2e32717b870f491233307117156f37c43fe9cc1b896eb7c915dfd15a98ef1b5f42cbfa86a185de1a794214f3c55805cff3b2ec4dd93bde8
MISC metadata.xml 385 BLAKE2B 6df98f89bbc4f9ce1e05dc86970c81d31f70559d4b87fd4d3908ceb1183906c1195544b2e99e96931ee26985f5e02b7fb4b036d8e6cd03c389cbe5764b964111 SHA512 ad748afd533651881c58295101e82097a0c4f4c15b205f4836315832ea3c08ee7cbbe18f652d09048c08532a3fe03b5fdd1f9da48d3378fac8624984c74df794
diff --git a/dev-python/xmltodict/xmltodict-0.11.0.ebuild b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
index c192afe51f3c..82cdb090f37b 100644
--- a/dev-python/xmltodict/xmltodict-0.11.0.ebuild
+++ b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Makes working with XML feel like you are working with JSON"
@@ -11,7 +11,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/xmltodict/xmltodict-0.12.0.ebuild b/dev-python/xmltodict/xmltodict-0.12.0.ebuild
new file mode 100644
index 000000000000..66d1067a4219
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.12.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.org/project/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}