summaryrefslogtreecommitdiff
path: root/dev-python/xmltodict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/xmltodict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/Manifest3
-rw-r--r--dev-python/xmltodict/metadata.xml12
-rw-r--r--dev-python/xmltodict/xmltodict-0.11.0.ebuild22
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/xmltodict/Manifest b/dev-python/xmltodict/Manifest
new file mode 100644
index 000000000000..3993258326dc
--- /dev/null
+++ b/dev-python/xmltodict/Manifest
@@ -0,0 +1,3 @@
+DIST xmltodict-0.11.0.tar.gz 26589 BLAKE2B 29498ac9c2f80828aa24d6cc4866aa6846fe10eb411a3e3617d85989c88628cc7c87ab80adb9ded492545fa2b4796a14b540479da75bfe464d1dfd811bbe1dc9 SHA512 d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295
+EBUILD xmltodict-0.11.0.ebuild 622 BLAKE2B 63614eee22369c3bb1e001ac93925cc6a2473dc0dd66f82289c962c2a23052c0a1acb6aa115d8927acb8a1d5cce8ed647dc5b304fb77febaea6f2b3c992f77a2 SHA512 3e8de2f6817dd46338e22777ea60666e4f37a71b0dc1b235645b811c02368fd4941d7982ef21408b15e7d18f9363764f85d8f26bcc0c97a276cc63de33e27734
+MISC metadata.xml 385 BLAKE2B 6df98f89bbc4f9ce1e05dc86970c81d31f70559d4b87fd4d3908ceb1183906c1195544b2e99e96931ee26985f5e02b7fb4b036d8e6cd03c389cbe5764b964111 SHA512 ad748afd533651881c58295101e82097a0c4f4c15b205f4836315832ea3c08ee7cbbe18f652d09048c08532a3fe03b5fdd1f9da48d3378fac8624984c74df794
diff --git a/dev-python/xmltodict/metadata.xml b/dev-python/xmltodict/metadata.xml
new file mode 100644
index 000000000000..ec7f1c3de1c5
--- /dev/null
+++ b/dev-python/xmltodict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">xmltodict</remote-id>
+ <remote-id type="github">martinblech/xmltodict</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xmltodict/xmltodict-0.11.0.ebuild b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
new file mode 100644
index 000000000000..988861cb9114
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.org/project/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}