summaryrefslogtreecommitdiff
path: root/dev-python/xlutils/xlutils-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/xlutils/xlutils-1.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/xlutils/xlutils-1.7.1.ebuild')
-rw-r--r--dev-python/xlutils/xlutils-1.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xlutils/xlutils-1.7.1.ebuild b/dev-python/xlutils/xlutils-1.7.1.ebuild
new file mode 100644
index 000000000000..d72a7b005520
--- /dev/null
+++ b/dev-python/xlutils/xlutils-1.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="provides a collection of utilities for working with Excel files"
+HOMEPAGE="https://pypi.python.org/pypi/xlutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/xlwt-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-0.7.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/errorhandler[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/testfixtures-1.6.1[${PYTHON_USEDEP}] )"
+
+DOCS="README.txt docs/*.txt"
+
+python_test() {
+ py.test xlutils/tests
+}