summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
commitcf1a411e806b434c96329401a6ff0901ec7f0d5c (patch)
tree969527fcceb3b686400c73b5ed22c1d587a8eb3e /dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild
parent6a01345ec5dc673d0ebd4653ceb063eafa7fcf65 (diff)
gentoo auto-resync : 18:04:2025 - 08:46:04HEADmaster
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild b/dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild
new file mode 100644
index 000000000000..74d9c3e565a2
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-3.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="
+ https://github.com/jmcnamara/XlsxWriter/
+ https://pypi.org/project/XlsxWriter/
+"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}