summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
commita493ba7d75043e8e649ee8d6d4942c1f4b31d1c5 (patch)
treed9aef2725cb8f60bd6f5a47afa9778eb94114793 /dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
parentd7ef5a07f47da6898dcb2d1503790c59b0470571 (diff)
gentoo auto-resync : 29:12:2022 - 02:14:02
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild b/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
new file mode 100644
index 000000000000..eb7598818634
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="
+ https://github.com/jmcnamara/XlsxWriter/
+ https://pypi.org/project/XlsxWriter/
+"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest