summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
new file mode 100644
index 000000000000..aca5569eed84
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="XlsxWriter"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+ test? ( https://github.com/jmcnamara/XlsxWriter/archive/RELEASE_${PV}.zip -> ${P}-tests.zip )
+
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/unzip
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ if use test; then
+ cp -r "${WORKDIR}"/${MY_PN}-RELEASE_${PV}/${PN}/test ${PN}/ || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v -v || die
+}