summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
deleted file mode 100644
index 8b195492bc4e..000000000000
--- a/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="XlsxWriter"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python module for creating Excel XLSX files"
-HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
- test? ( https://github.com/jmcnamara/XlsxWriter/archive/RELEASE_${PV}.zip -> ${P}-tests.zip )
-
-"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( app-arch/unzip
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
- if use test; then
- cp -r "${WORKDIR}"/${MY_PN}-RELEASE_${PV}/${PN}/test ${PN}/ || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v -v || die
-}