summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
deleted file mode 100644
index aca5569eed84..000000000000
--- a/dev-python/xlsxwriter/xlsxwriter-0.9.8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="XlsxWriter"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python module for creating Excel XLSX files"
-HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
- test? ( https://github.com/jmcnamara/XlsxWriter/archive/RELEASE_${PV}.zip -> ${P}-tests.zip )
-
-"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( app-arch/unzip
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
- if use test; then
- cp -r "${WORKDIR}"/${MY_PN}-RELEASE_${PV}/${PN}/test ${PN}/ || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v -v || die
-}