summaryrefslogtreecommitdiff
path: root/dev-python/xkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
commitaf42afeb201514cfc34a8a056def3389af35a54b (patch)
treedc183d93580761fd7e856068e25c046c6a53396d /dev-python/xkbcommon
parent26c687603afd123f35f1b8745cb38493a4e7d928 (diff)
gentoo auto-resync : 12:01:2023 - 11:46:19
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest3
-rw-r--r--dev-python/xkbcommon/metadata.xml11
-rw-r--r--dev-python/xkbcommon/xkbcommon-0.8.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
new file mode 100644
index 000000000000..b3f4945c1650
--- /dev/null
+++ b/dev-python/xkbcommon/Manifest
@@ -0,0 +1,3 @@
+DIST xkbcommon-0.8.gh.tar.gz 26951 BLAKE2B 0d2a649e3fee8baa9345ddca97dc7c77b5d9e10d7ca90cbb29bcc3531f4bba3deee39e610e147054e956310506fb79ebb43c85955b787e55046d67c12b851026 SHA512 ae2640ef89e7ace0468e970762c7be4d3f608701f1abea10174f274c622db28a6e6323cdc5bbbbaaa1065d4c4ddf9f67b75d4c34bb2e9a0bb6260778b15a330a
+EBUILD xkbcommon-0.8.ebuild 805 BLAKE2B b6fd8575dd5d670175d91170d56a2d0dc118ed177533e043987eef44916feb87d498235f9594f62cf1b7fe1995bc452333611d8659a2859155bb941c1cd3a84c SHA512 546ffef534ea96b15d4a68186e089a3afab523a69688c83c1885f01550ae1aebe6bad3b9be77c0ee7ccdd923110075058c4f875cc1b8408e4269f1e91889439c
+MISC metadata.xml 355 BLAKE2B fef5c9392775c817ce5754bc6c70a30048e0aa252593229667b515d27421e95377f2199c121f43b112ef957a4172440417221fecf30ce9d068b23278bc2e2e4a SHA512 21fd7e00d1b727d6b281977fa4659c620259577dc346213437af17742ee4ceff367e0ccd45c8bb03f15afe6c0a1c885e1b3f9ebbd47b50518ec2953580b17df4
diff --git a/dev-python/xkbcommon/metadata.xml b/dev-python/xkbcommon/metadata.xml
new file mode 100644
index 000000000000..0dfaf46622c1
--- /dev/null
+++ b/dev-python/xkbcommon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sde1000/python-xkbcommon</remote-id>
+ <remote-id type="pypi">xkbcommon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xkbcommon/xkbcommon-0.8.ebuild b/dev-python/xkbcommon/xkbcommon-0.8.ebuild
new file mode 100644
index 000000000000..55f11ee550b5
--- /dev/null
+++ b/dev-python/xkbcommon/xkbcommon-0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libxkbcommon using cffi"
+HOMEPAGE="
+ https://github.com/sde1000/python-xkbcommon
+ https://pypi.org/project/xkbcommon/
+"
+SRC_URI="
+ https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}"/python-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# x11-libs/libxkbcommon dep per README
+RDEPEND="
+ >=x11-libs/libxkbcommon-${PV}
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -r xkbcommon
+
+ epytest
+}