summaryrefslogtreecommitdiff
path: root/dev-python/xkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /dev-python/xkbcommon
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest4
-rw-r--r--dev-python/xkbcommon/xkbcommon-0.8.ebuild16
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index 48b023a11734..0303552b48bf 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,3 +1,3 @@
-DIST xkbcommon-0.8.gh.tar.gz 26951 BLAKE2B 0d2a649e3fee8baa9345ddca97dc7c77b5d9e10d7ca90cbb29bcc3531f4bba3deee39e610e147054e956310506fb79ebb43c85955b787e55046d67c12b851026 SHA512 ae2640ef89e7ace0468e970762c7be4d3f608701f1abea10174f274c622db28a6e6323cdc5bbbbaaa1065d4c4ddf9f67b75d4c34bb2e9a0bb6260778b15a330a
-EBUILD xkbcommon-0.8.ebuild 833 BLAKE2B eeb63fbdf5ddc8591c091a0a4d72648c44f89e6556f4bd417a32f20d1e66b2d28196d2dda53fde8e61a6df1782709dd91f242f2a3f313e3bdb13377697b3e732 SHA512 36f58cdde584fb1e3e50f7d14cdc0e96602b07b43012ad962a933a2ebb3200ac732658eb8e385d540c7faed212e0e96319f0504894939bec428664fd2ace55ab
+DIST python-xkbcommon-0.8.gh.tar.gz 26951 BLAKE2B 0d2a649e3fee8baa9345ddca97dc7c77b5d9e10d7ca90cbb29bcc3531f4bba3deee39e610e147054e956310506fb79ebb43c85955b787e55046d67c12b851026 SHA512 ae2640ef89e7ace0468e970762c7be4d3f608701f1abea10174f274c622db28a6e6323cdc5bbbbaaa1065d4c4ddf9f67b75d4c34bb2e9a0bb6260778b15a330a
+EBUILD xkbcommon-0.8.ebuild 851 BLAKE2B c3d06c47edb4c163f13bff70d277a775b70e06599de3f516491f215b70e152ff0a08704edcfbeb94a587d87cbe6b0b0e0a528a56a67909c18323bb194a758b2e SHA512 14bf92ac35b818a8322c9da22528ff63e7fe35bd550d4d934273b3b95bcfdd5151501390d93e2f4e39386ccc00802542af9f9a1df3ca17c7c81e907e511adf16
MISC metadata.xml 355 BLAKE2B fef5c9392775c817ce5754bc6c70a30048e0aa252593229667b515d27421e95377f2199c121f43b112ef957a4172440417221fecf30ce9d068b23278bc2e2e4a SHA512 21fd7e00d1b727d6b281977fa4659c620259577dc346213437af17742ee4ceff367e0ccd45c8bb03f15afe6c0a1c885e1b3f9ebbd47b50518ec2953580b17df4
diff --git a/dev-python/xkbcommon/xkbcommon-0.8.ebuild b/dev-python/xkbcommon/xkbcommon-0.8.ebuild
index 4161cc0dc454..7055c24334cc 100644
--- a/dev-python/xkbcommon/xkbcommon-0.8.ebuild
+++ b/dev-python/xkbcommon/xkbcommon-0.8.ebuild
@@ -5,20 +5,21 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit distutils-r1
+MY_P=python-xkbcommon-${PV}
DESCRIPTION="Python bindings for libxkbcommon using cffi"
HOMEPAGE="
- https://github.com/sde1000/python-xkbcommon
+ https://github.com/sde1000/python-xkbcommon/
https://pypi.org/project/xkbcommon/
"
SRC_URI="
https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
+ -> ${MY_P}.gh.tar.gz
"
-S="${WORKDIR}"/python-${P}
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -27,15 +28,16 @@ KEYWORDS="amd64 ~riscv ~x86"
# x11-libs/libxkbcommon dep per README
RDEPEND="
>=x11-libs/libxkbcommon-${PV}
- virtual/python-cffi[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
"
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
python_test() {
- # No die deliberately as sometimes it doesn't exist
- rm -r xkbcommon
+ rm -rf xkbcommon || die
epytest
}