summaryrefslogtreecommitdiff
path: root/dev-python/xkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
commit4187bba080530c5ca1c7dae9c233e88f3fc8f535 (patch)
treeb6f535e053876097ced1b6bda14a4da890c730d4 /dev-python/xkbcommon
parent2a8d2f71d1d9963368e0ef3d641d75979a689d12 (diff)
gentoo auto-resync : 06:07:2024 - 08:06:15
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest4
-rw-r--r--dev-python/xkbcommon/xkbcommon-1.0.1.ebuild44
-rw-r--r--dev-python/xkbcommon/xkbcommon-1.5.ebuild38
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index 41a1f9837f23..1acf8127ee82 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,3 +1,7 @@
+DIST python-xkbcommon-1.0.1.gh.tar.gz 79263 BLAKE2B 8bc128e592a02b14321fe087f7c0ae87a699e0284c3230fa2a0b1cf2e8105037fa0ace876216ec8a72cc49eb76fab0af83b7a5d83a3943f609954205d949def0 SHA512 1e0393c5d7e99d9a68168a5486a15b3598d8539b7a7b0a7c41a9c1a329cfe79d3f19556b481f5625e1bea1cc41f3394dcc1fc1bf1dbd98cd58db54f471ece5d5
DIST python-xkbcommon-1.0.gh.tar.gz 27258 BLAKE2B 3106877f8e87f50453a358eec4e6431642b00a6a2bc23d3088ef22379984869ec84cd042a1ac53dd72783f3005dad1efddf3f87410204b88bfde4f9da0044c97 SHA512 c7793d6f5517771006ff5a9c01deb9a37717157d7171af49ff459dc96b3b16a1d2d4c0f1272b5a8f683390de1e8e6a6ff92472f18828c7e38e0f2a1ee6f34f07
+DIST xkbcommon-1.5.tar.gz 79887 BLAKE2B f6a39b98fc97f12a2badfa53cf5445fad0018aaf03542d1945d36155e3c0abe92b4080f149d8c2bcc85ac72cef6a6099ca45afb043754b31a543f02820a33ebd SHA512 ab0d3f83d11038dd4ae98f9954f6082f214727720d0eced4c298943f4f26b19d9be42bc4215c4e6a5fa68214c4a0a5e88b30657a52e982a8b4c7e7b84c1c174b
+EBUILD xkbcommon-1.0.1.ebuild 900 BLAKE2B 4ba5443c5f5cd428f80fa9b4d258104d1c2276ab82cd03b2d5441c0e912fad9ea6fc4bcb8a46a17b11476e537353d82a825a417131407dbfa5bbcc0437720f6b SHA512 ff3e628fb9bf74479f2af1ce251ca40148ee3f8adcca6516d90b13c3aa68cd0c83980999a702cbdeb94f57a6a05c10223cc5c97e08c372943fb95dedd27dc9cf
EBUILD xkbcommon-1.0.ebuild 856 BLAKE2B 80e0c98d0cc44b04dad46821a87a47628efe395c8feacaa70549b5625b4d351e5766a5990db9939fb1b1568d9054adcca90a5680c38f6c9fe3dff80f5297c894 SHA512 27406451b5ae1916ad02c7f1dba080da62e07281048bfd9634c408574c3258b22b200a3a656f3739a0724c4b4e523d03265f37585290ede28f34bc71d61f3e87
+EBUILD xkbcommon-1.5.ebuild 744 BLAKE2B 34825c64c20b4af17dd06a7541b32b0ec6da78611353cc971cfc52ab85230a5db66b1c956c408a94a9cbf69d9dcc6a9f56a345ce28ed1823871e6bc4e07770b4 SHA512 539b1bb2bcdd69aef51c6dab491473ede0cbe3c02aaf6b164712b8fa9ed5a06ed1c80904a0d86ff935a877c2a4aac0e68309cd2bec0558fea0c4e6c1a680137f
MISC metadata.xml 355 BLAKE2B fef5c9392775c817ce5754bc6c70a30048e0aa252593229667b515d27421e95377f2199c121f43b112ef957a4172440417221fecf30ce9d068b23278bc2e2e4a SHA512 21fd7e00d1b727d6b281977fa4659c620259577dc346213437af17742ee4ceff367e0ccd45c8bb03f15afe6c0a1c885e1b3f9ebbd47b50518ec2953580b17df4
diff --git a/dev-python/xkbcommon/xkbcommon-1.0.1.ebuild b/dev-python/xkbcommon/xkbcommon-1.0.1.ebuild
new file mode 100644
index 000000000000..ee7ef4fcf845
--- /dev/null
+++ b/dev-python/xkbcommon/xkbcommon-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-xkbcommon-${PV}
+DESCRIPTION="Python bindings for libxkbcommon using cffi"
+HOMEPAGE="
+ https://github.com/sde1000/python-xkbcommon/
+ https://pypi.org/project/xkbcommon/
+"
+SRC_URI="
+ https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# x11-libs/libxkbcommon dep per README
+RDEPEND="
+ >=x11-libs/libxkbcommon-${PV}
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf xkbcommon || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/xkbcommon/xkbcommon-1.5.ebuild b/dev-python/xkbcommon/xkbcommon-1.5.ebuild
new file mode 100644
index 000000000000..ff9443b3c9b7
--- /dev/null
+++ b/dev-python/xkbcommon/xkbcommon-1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libxkbcommon using cffi"
+HOMEPAGE="
+ https://github.com/sde1000/python-xkbcommon/
+ https://pypi.org/project/xkbcommon/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# x11-libs/libxkbcommon dep per README
+RDEPEND="
+ >=x11-libs/libxkbcommon-${PV}
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf xkbcommon || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}