summaryrefslogtreecommitdiff
path: root/dev-python/xdg/xdg-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/xdg/xdg-5.1.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/xdg/xdg-5.1.0.ebuild')
-rw-r--r--dev-python/xdg/xdg-5.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xdg/xdg-5.1.0.ebuild b/dev-python/xdg/xdg-5.1.0.ebuild
new file mode 100644
index 000000000000..6f45c65fcd8c
--- /dev/null
+++ b/dev-python/xdg/xdg-5.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of the XDG Base Directory Specification in Python"
+HOMEPAGE="https://github.com/srstevenson/xdg/ https://pypi.org/project/xdg/"
+SRC_URI="
+ https://github.com/srstevenson/xdg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# https://bugs.gentoo.org/773415
+RDEPEND="!dev-python/pyxdg"
+
+distutils_enable_tests pytest