summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
commitbfc2a8298cab03d289dc2cfed63308396fa0babe (patch)
tree2d4288572b0938dcfc64edd39a4c1086402931a5 /dev-python/xarray
parente28a6e6eb5373071be3a09aa457f0488d753c80c (diff)
gentoo auto-resync : 24:06:2023 - 13:27:08
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2023.6.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 28b2e0c54bb7..f22982c8e4bf 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,5 +1,7 @@
DIST xarray-2023.4.2.tar.gz 3692437 BLAKE2B d4fb5b184386bb7e9574ea3bdf484c3df82b9dca1fcd2380ac65b6a58da9f89da057d70efa9bd045b5cf6900c38f6aa4176fd2990cfe1369f987c452711307d6 SHA512 581b06a677b80c0f7e494a80ae52d75bd62bf613b13b7b7215458ceef727fb55a898c8da8cc6f8a6875ef6898007897eea8be55fb138f1dacad42965bbf1d956
DIST xarray-2023.5.0.tar.gz 3707468 BLAKE2B 55ee416c41aff8edcb609adcac1c0a2e1d4ae896c25ae3d771d755930725f69f854feac42c42558db598acc5d0a852370198908d85d5af9664c485052948f4ca SHA512 ab6538b280f05acc296d8d73003e07f494d330a2a6a486d2f3dac121aee9682e2fa46c05be868b23a31584c908e0f6454757bdac7ec032d3a6f79a4500c0629f
+DIST xarray-2023.6.0.tar.gz 3711562 BLAKE2B 3b6b20cf0046aaeeafe87980c6c107486d79afd2881c4f98b42c17025f0d448763d37b5d5fd71cf17fcfcfbdc2d3337e985c7517038547300f4cf57ffe1aea98 SHA512 2b1b48bd90935a3b56f5f017085d40cc10081efbe0a84c908d1203066f29b4bf16fc89e771d961f26009bb20a84a59f4b9d99e42b5e25b2bbd8eca55a80839d6
EBUILD xarray-2023.4.2.ebuild 1818 BLAKE2B 22c9fc2cff1140db3344c7569a26b8bbf261d6a17ffea5b6f717cf19da58a7c4789eed1b7e180b2d24f60b03eae4e2d5f00563e74deb03c035e400712b84493a SHA512 195567c43d228a5b0ab9c742de11b07b692ee52e8d07e410f83a11e0b527da0cece4693d6560b92741f4c6c27a55daeda30be12c7a32faaab79b514380712478
EBUILD xarray-2023.5.0.ebuild 1824 BLAKE2B 1d6ade565018e67ef55e6bb444a0b2b46a0147d47896e058f47a17969480af79ed74e0f65295832bb91074bb3050850597073cba3a600dceaa76eb33ac4c4a7b SHA512 b43dea73b156cf9439dec5648ccdd6f3f86a68f77769e77940918d2fab6b3e1209d63aca67508efa3fcb13a332fbfc8b0e78fdfb215ac2f4fd5f37de642ec200
+EBUILD xarray-2023.6.0.ebuild 1912 BLAKE2B 77a610509f3b28e3faabb7c13af10bb1644ce205906393267e20e5321a2f9b59e9910dfce5887d4855bb7ae632d7c9614051275329c0d7c43089815e5757b1f0 SHA512 fa59f2fb826c61ca5ab600b620032d0161e6f79862fc090943b2d0d0e005234413e332a51a86f524f291110cae6207822250333f620419479d25112d63cdb036
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2023.6.0.ebuild b/dev-python/xarray/xarray-2023.6.0.ebuild
new file mode 100644
index 000000000000..6672e7602e28
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
+}