summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-2022.10.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
commit268f9f01921ccb921b794d43092c5f29c1e96c56 (patch)
tree07329b3a8cb5d315182a2ec2b2f4a4b36374724d /dev-python/xarray/xarray-2022.10.0-r1.ebuild
parente3a48e635527f3e2d2254e9631f7a5758df9c3fb (diff)
gentoo auto-resync : 08:01:2023 - 06:15:27
Diffstat (limited to 'dev-python/xarray/xarray-2022.10.0-r1.ebuild')
-rw-r--r--dev-python/xarray/xarray-2022.10.0-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/xarray/xarray-2022.10.0-r1.ebuild b/dev-python/xarray/xarray-2022.10.0-r1.ebuild
deleted file mode 100644
index 9c1ebc293c6a..000000000000
--- a/dev-python/xarray/xarray-2022.10.0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="https://xarray.pydata.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
-"
-# note: most of the test dependencies are optional
-BDEPEND="
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
-)