summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-0.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/xarray/xarray-0.19.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/xarray/xarray-0.19.0.ebuild')
-rw-r--r--dev-python/xarray/xarray-0.19.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/xarray/xarray-0.19.0.ebuild b/dev-python/xarray/xarray-0.19.0.ebuild
deleted file mode 100644
index 0315b612b3d6..000000000000
--- a/dev-python/xarray/xarray-0.19.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# pkg_resources use in code
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="https://xarray.pydata.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
-# note: most of test dependencies are optional
-BDEPEND="
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
- )
-
- epytest ${deselect[@]/#/--deselect }
-}