summaryrefslogtreecommitdiff
path: root/dev-python/wxpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/wxpython
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/Manifest1
-rw-r--r--dev-python/wxpython/wxpython-4.0.7-r1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index 6e9e8d51075a..75d40673b707 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -1,5 +1,6 @@
AUX wxpython-4.0.6-no-webkit.patch 1411 BLAKE2B 222f85e79f55420ca2b04b3ba6a30293646f84894a45ac2b72852e3f72f187e333b2efd6d76cc02c5996ae75725ef40e882d45012c492b7f3a478666a01d0189 SHA512 82539d4ec63a8b21576de38b17fe2fdf095443b4cfeabf369c443d818ce402e62dcf257ccba022c3b0d671f914f5ef88e4ff40b9fc7d6276493c9a8caf2b76fa
AUX wxpython-4.0.6-skip-broken-tests.patch 4113 BLAKE2B 920f1c0c6e1154de83c412ffdfa4b3276d01a5e9be8998be42634368f34217bd5b6505abced2ec3479b9ab4f40a5697405983740e599b76be1725bb963e3311e SHA512 04201012f1cc16913ff53a9d4868dbdaa6915b1a3a33f0342572aa56741207b6de6e274b91cd26a06511ae8d79d7fef247c2cababafd57130417caa4463a409a
DIST wxPython-4.0.7.post2.tar.gz 68891167 BLAKE2B 77eb69f7a59e5be81c3d17b64c76e09a43efc9226bd87fd058483185871a95ce05dbb65614ec8b003edf52cbe1cb1a115856c0d622170c51ecacbb952106fe22 SHA512 7af89db90a0f7e6b644d61c1ede01ec36a2c295e46d44692ae9dbc4af923310c1b498a52f45b02a89e8917d844c6abe67e5f3fdd9c1d51da3312899319a349e4
+EBUILD wxpython-4.0.7-r1.ebuild 2349 BLAKE2B fd3d0cdcf1329592a47f489bd0db216dafa28342bd9c4490f6639bc31d2fa51dde89d35546e65a3ee5a0be3ca683c578f5cbc09da58b0d9f621d6fa40e7b9da9 SHA512 6137383cb8a368c521fb67dfaaa34b488eb5090a1e4f590a9c9cb50562da29debfaf7542c1b456c43106739dfc9e6e9b01e255e5f07ddb9ec066877b08765cae
EBUILD wxpython-4.0.7.ebuild 2312 BLAKE2B a52439c2f604250fb09d6c94509d611fbfee7031d8126966ebd0fbef8aa3e53ba32c51bedb3cea774b1abff9528a7218a1ae4c3df5929e89cbb387ef48e197e8 SHA512 d78319bca605cee9e167ca8f684dd2766810eb4d76b364a7adb4663bbc5e8927a61d81a2a718d7c98d8ea2942b24a67d48bdb42bb13c18ec6fe12a3c919bcc86
MISC metadata.xml 490 BLAKE2B b268c95de8e09d5027a6dff7413f8e85030c64610f0f5739321bca1c66892981e2e4273e3e4fc92f3edbbcee1d2ede23a366dfec9ffbc17c8b015b784847755f SHA512 a33e6390e4cfcedbe7a2e950b1f447195f439747e37acfa6ad234b58fd449d80b16d342213e5190fa3143c71a5e95861f11daff1b61fcb5015c3a5255a27cadb
diff --git a/dev-python/wxpython/wxpython-4.0.7-r1.ebuild b/dev-python/wxpython/wxpython-4.0.7-r1.ebuild
new file mode 100644
index 000000000000..7585b66bcd42
--- /dev/null
+++ b/dev-python/wxpython/wxpython-4.0.7-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+WX_GTK_VER="3.0-gtk3"
+
+DISTUTILS_IN_SOURCE_BUILD="1"
+
+inherit distutils-r1 multiprocessing virtualx wxwidgets
+
+MY_PN="wxPython"
+MY_PV="${PV}.post2"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="https://www.wxpython.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test webkit"
+# Tests broken: #726812, #722716
+RESTRICT="test"
+#RESTRICT="!test? ( test )"
+
+# wxPython doesn't seem to be able to optionally disable features. webkit is
+# optionally patched out because it's so huge, but other elements are not,
+# which makes us have to require all features from wxGTK
+RDEPEND="
+ >=x11-libs/wxGTK-3.0.4-r301:${WX_GTK_VER}=[gstreamer,libnotify,opengl,sdl,tiff,webkit?,X]
+ media-libs/libpng:0=
+ media-libs/tiff:0
+ virtual/jpeg:0"
+
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"
+)
+
+python_prepare_all() {
+ if ! use webkit; then
+ eapply "${FILESDIR}/${PN}-4.0.6-no-webkit.patch"
+ rm unittests/test_webview.py || die
+ fi
+ # Most of these tests disabled below fail because of the virtx/portage
+ # environment, but some fail for unknown reasons.
+ rm unittests/test_uiaction.py \
+ unittests/test_notifmsg.py \
+ unittests/test_mousemanager.py \
+ unittests/test_display.py \
+ unittests/test_pi_import.py \
+ unittests/test_lib_agw_thumbnailctrl.py \
+ unittests/test_sound.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ setup-wxwidgets
+}
+
+python_compile() {
+ DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+ ${PYTHON} build.py build_py \
+ --use_syswx \
+ --no_magic \
+ --jobs=$(makeopts_jobs) \
+ --release || die
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}
+
+python_test() {
+ virtx pytest -vv unittests
+}