summaryrefslogtreecommitdiff
path: root/dev-python/wxpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-14 08:45:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-14 08:45:05 +0100
commit4e995247a9a9d45f0b265ab9120c6d31c0a1f0d9 (patch)
treeb8330005bca4333e931cf74629b98e71aa5e608b /dev-python/wxpython
parentca533b9b46b871263ead04dcb28165df09a3f282 (diff)
gentoo auto-resync : 14:04:2025 - 08:45:05
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/Manifest2
-rw-r--r--dev-python/wxpython/wxpython-4.2.3-r1.ebuild (renamed from dev-python/wxpython/wxpython-4.2.3.ebuild)8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index 8dcc945af027..f8ddfa6beec4 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -16,5 +16,5 @@ DIST wxPython-4.2.3.tar.gz 58861286 BLAKE2B 2c674227ff109564be1431f2a86a212250ff
EBUILD wxpython-4.2.0.ebuild 3924 BLAKE2B 5f72d886f806375ee130a7170f239bf406961760cfd30e00e5fb3ca9d1eca9c1971e058046612636b3a574ff48f8fbc48e5a8c6044cf518ccdf3aa57871ad530 SHA512 936f595d4adeabd48c040dafd371b98a30927c73f955ff4fb29de9ea210fc67a3efd51686389e791f2ed6a384f59b8c45eab57f2e01c42d52f716e97110bd07d
EBUILD wxpython-4.2.1-r2.ebuild 4021 BLAKE2B d5ae34fe1dc137b1e0075091c25ab8a91dad8a4069b954b589b5732ae69bced4cd22f346ece9b84e5733505058b8f79ae9a5d60d98a9fdd96bf8726879003ed0 SHA512 e8f79de70a1808130b8c4963e3f18a458ae2841585065c9ab9a845438deb160b274fa0a734a2e4e24ae814d0f0c6405a4469f3004aebb770ed188e35e0d21f83
EBUILD wxpython-4.2.2.ebuild 4096 BLAKE2B fb1eef9d60f2c5f5a4a9c3592888fd3c1255582da4e7313a45930682ee7e1ce283a3c75145fc16d80bf60176b8d71b5eafc17dbf36500c778e73c7a65e6466a0 SHA512 e053588be37bc9e403f0d77b2fc7bb2d68c06350552d5e17e0c08543168d3e46891fa0a45c3846ba87f41be8cb56140f158c35b5fec063c65d14bb992cf9ba30
-EBUILD wxpython-4.2.3.ebuild 3810 BLAKE2B ec62bd03f0e7b7a108615fe88ce5defde216032e27fd4cb5e06b1057eeff6c89c93c0be40ebe82963d457e5b7284af37ea5aa1bbf005957d44735e09465f1d0b SHA512 6eb82978fc3293a8cb82e7c8b6d229ae00856aae3664fcc1220d1471609928ee92dbeef36bce0ffd8a6bcad98edad991a9c1cad7746bc3cfb6c5c8aef8b5934b
+EBUILD wxpython-4.2.3-r1.ebuild 4025 BLAKE2B fcb48b0d85f834c180f55be27e73ccea6fd389901c28c8e9e3c3bbfe3479850c0e04c5df84c5a6447286e577b48f2824952614382e6f0e49b26746a42aaf201a SHA512 844dfa2ee88eb67ee51ec19f12c506782d74d1f92dbf3f23d795b6d1a15b6c8f06337cf40fc8bef9e72692eae6fc812185f848794f850ff8d74d76bc0035c949
MISC metadata.xml 491 BLAKE2B ffa0cccf66f484c856fb30249bd0ccc3b0da2f3ee8e3c3a0df1782bc58e4867ff99d9711f1784b44b439f2a8bcf297c1082b49a941823f046c7f2c7977a77629 SHA512 a2f5908a276a8f9c512cb59c8d17873398c91b21977371ab724e669f3b6c032d53510fbcd183a5dc340279fc522289e617b8c313c0d825ca70d0d2a5d74f8cfa
diff --git a/dev-python/wxpython/wxpython-4.2.3.ebuild b/dev-python/wxpython/wxpython-4.2.3-r1.ebuild
index 83789483cd5e..d6cfd1105668 100644
--- a/dev-python/wxpython/wxpython-4.2.3.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.3-r1.ebuild
@@ -9,7 +9,7 @@ PYPI_NO_NORMALIZE=1
PYPI_PN="wxPython"
WX_GTK_VER="3.2-gtk3"
-inherit distutils-r1 multiprocessing virtualx wxwidgets pypi
+inherit distutils-r1 multilib multiprocessing virtualx wxwidgets pypi
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="
@@ -95,6 +95,11 @@ python_compile() {
distutils-r1_python_compile
+ # This package's built system relies on copying extensions back
+ # to source directory for setuptools to pick them up. This is
+ # hopeless.
+ find -name "*$(get_modname)" -delete || die
+
cp "${S}/sip_corewxAppTraits.cpp" "${S}/sip/cpp/" || die
}
@@ -128,6 +133,7 @@ python_test() {
EPYTEST_IGNORE+=( unittests/test_webview.py )
fi
+ rm -rf wx || die
# We use pytest-forked as opensuse does to avoid tests corrupting each
# other.
virtx epytest --forked unittests