summaryrefslogtreecommitdiff
path: root/dev-python/wxpython/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /dev-python/wxpython/files
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'dev-python/wxpython/files')
-rw-r--r--dev-python/wxpython/files/wxpython-4.2.2-no-stacktrace.patch16
-rw-r--r--dev-python/wxpython/files/wxpython-4.2.2-setuppy.patch38
-rw-r--r--dev-python/wxpython/files/wxpython-4.2.2-sip-6.10.0.patch14
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/wxpython/files/wxpython-4.2.2-no-stacktrace.patch b/dev-python/wxpython/files/wxpython-4.2.2-no-stacktrace.patch
new file mode 100644
index 000000000000..f387612522bd
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-4.2.2-no-stacktrace.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/924057
+
+--- a/sip/cpp/sip_corewxAppTraits.cpp
++++ b/sip/cpp/sip_corewxAppTraits.cpp
+@@ -471,7 +471,11 @@
+ PyErr_Clear();
+
+ Py_BEGIN_ALLOW_THREADS
++ #ifdef __GLIBC__
+ sipRes = new ::wxString((sipSelfWasArg ? sipCpp->::wxAppTraits::GetAssertStackTrace() : sipCpp->GetAssertStackTrace()));
++ #else
++ sipRes = new ::wxString("");
++ #endif
+ Py_END_ALLOW_THREADS
+
+ if (PyErr_Occurred())
diff --git a/dev-python/wxpython/files/wxpython-4.2.2-setuppy.patch b/dev-python/wxpython/files/wxpython-4.2.2-setuppy.patch
new file mode 100644
index 000000000000..229d372aa5af
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-4.2.2-setuppy.patch
@@ -0,0 +1,38 @@
+Created by Quincy Fleming
+https://bugs.gentoo.org/909973
+
+--- a/setup.py
++++ b/setup.py
+@@ -113,6 +113,7 @@
+ """
+ user_options = [
+ ('skip-build', None, 'skip building the C/C++ code (assumes it has already been done)'),
++ ('buildpy-options=', None, 'string of commands and options passed to build.py'),
+ ]
+ boolean_options = ['skip-build']
+
+@@ -120,6 +121,7 @@
+ def initialize_options(self):
+ orig_build.initialize_options(self)
+ self.skip_build = '--skip-build' in sys.argv
++ self.buildpy_options = 'build'
+
+ def finalize_options(self):
+ orig_build.finalize_options(self)
+@@ -135,7 +137,7 @@
+ 'message and the wxWidgets and Phoenix build steps in the future.\n')
+
+ # Use the same Python that is running this script.
+- cmd = ['"{}"'.format(sys.executable), '-u', 'build.py', 'build']
++ cmd = ['"{}"'.format(sys.executable), '-u', 'build.py',self.buildpy_options]
+ cmd = ' '.join(cmd)
+ runcmd(cmd)
+
+@@ -143,7 +145,6 @@
+ # build/lib folder like normal.
+ orig_build.run(self)
+
+-
+ def _cleanup_symlinks(cmd):
+ # Clean out any libwx* symlinks in the build_lib folder, as they will
+ # turn into copies in the egg since zip files can't handle symlinks.
diff --git a/dev-python/wxpython/files/wxpython-4.2.2-sip-6.10.0.patch b/dev-python/wxpython/files/wxpython-4.2.2-sip-6.10.0.patch
new file mode 100644
index 000000000000..7f15661b601f
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-4.2.2-sip-6.10.0.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/949510#c4
+https://github.com/wxWidgets/Phoenix/commit/de9aa4be5bb49adf82991c7582ea3c42ed505bf7.patch
+
+--- a/buildtools/config.py
++++ b/buildtools/config.py
+@@ -85,7 +85,7 @@
+ PKGDIR = 'wx'
+ # The name of the top-level package
+
+- SIP_ABI = '12.9'
++ SIP_ABI = '12.14'
+ SIP_TRACE = False
+
+ # ---------------------------------------------------------------