summaryrefslogtreecommitdiff
path: root/dev-python/wtforms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
commit82002be95de85b10f5953f5e10ced81a40ec1fba (patch)
tree3e95915eeab9799a67d9b0c508260ca31a4694ab /dev-python/wtforms
parentfc6ff4de73d70ead4ce3a005b4f5328f2b23129b (diff)
gentoo auto-resync : 11:10:2023 - 00:10:45
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/Manifest2
-rw-r--r--dev-python/wtforms/wtforms-3.1.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 60436af71c2e..a3fc1139096f 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,3 +1,5 @@
DIST WTForms-3.0.1.tar.gz 137513 BLAKE2B 17fbb385a28baefaf3fe368b7c7dbd3d6671aaef887ee89617e60e0537ae060248442d4990e7ea926b15d4b85585a1c80ffb61c0fdad2627e5cca90799eb01d7 SHA512 a6db54a7ef9bc96b8fdf69cd65d3810fab9436ff9c056e1cfc580f5ecd0ed8837dcbb7c2adf92419cc5f74e865bb3a023e316407a87d5c5277da5d30e6836fb3
+DIST wtforms-3.1.0.tar.gz 134500 BLAKE2B a88f29eb600b50f7de964d9cef1dd195f7731312bf291b3cbfa1664537c4eb242a59d435994c007c2e84eaf19942db5316e58154639bdd8ebee85d336ca5a9dc SHA512 6afc9bb2980668c753887945692525a4039e7a06fb3f0e2b56d1a60c382f099e1b75d722f19786ec0f32a1043b4909b1be28c8aeccadc4745785414835aebf02
EBUILD wtforms-3.0.1-r1.ebuild 829 BLAKE2B b888b42cdbb5cff6c30c829827a1a859e7ba6fa8c3ed3a95f485b9b4060b3ea9c9d7a298e626714334a3667bee297d5ee58a08dfd8b0727340cdcba7ce4d8a4d SHA512 4422d1fc4d076c4f39e6310ec421142eef147b9a2a3a851b89fae05c571f4091ddb5cad6a917871ec4adc60a3316da38f44885cee78f25eef2ec2d6fd678f56b
+EBUILD wtforms-3.1.0.ebuild 810 BLAKE2B 5234583e0e74b83401d9ab2636fc2d3d34214ca15815107c6d9546bd71c142446e56a461d5f0b48e1bfa4702ecae717f8e5db8e2cba47528e6e42ce3a74f4831 SHA512 1fa92dcc8cfea97baed8a92ee76546d1755a6cb441e009543952cb43a62b84dea4fde626fa3ed0178c21a6a297bcbf422e3aeca6a986c208ed57186b8dbbe5f9
MISC metadata.xml 453 BLAKE2B 24b826025af54d17f8773a9583b369eabc3be6265d26d5fed67d562ff5e2abdb6318e8905d1c1173d399587017c35efe68486f1616e3c1ebb08f1283e2c28985 SHA512 de936c361da6f4b1e64374215c3d2502c77c083a7544e77c77d5b7dc8e6570622a218047651845907d26fb60ab972dc00cc70979df42b888c0cd3373f63e2ebb
diff --git a/dev-python/wtforms/wtforms-3.1.0.ebuild b/dev-python/wtforms/wtforms-3.1.0.ebuild
new file mode 100644
index 000000000000..718aeb1fb598
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN="WTForms"
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="
+ https://wtforms.readthedocs.io/
+ https://github.com/wtforms/wtforms/
+ https://pypi.org/project/WTForms/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/email-validator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest