summaryrefslogtreecommitdiff
path: root/dev-python/wstools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wstools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wstools')
-rw-r--r--dev-python/wstools/Manifest6
-rw-r--r--dev-python/wstools/files/wstools-0.4.5-setup.patch46
-rw-r--r--dev-python/wstools/metadata.xml12
-rw-r--r--dev-python/wstools/wstools-0.4.3.ebuild21
-rw-r--r--dev-python/wstools/wstools-0.4.5-r1.ebuild34
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
new file mode 100644
index 000000000000..e4513b86bd14
--- /dev/null
+++ b/dev-python/wstools/Manifest
@@ -0,0 +1,6 @@
+AUX wstools-0.4.5-setup.patch 1874 BLAKE2B e23a2b8b183079bdc72a7304d0df03b4884c277f287b2444e2bfea9db8fa0344c8817d2316d17cff3d654c3eec3fed448ed200d1f873f6b8f85add6b81ca60a0 SHA512 ee0e9523de4f31bc98a993561e55004a9f877160c1f7a83b9ec83d0654a770972cdefe67692dbd01e322f507370aeee8c2927326ec1797c9c81ff52e085955fd
+DIST wstools-0.4.3.tar.gz 148878 BLAKE2B 96b1e9dc0310fb0fc5515a7c061f82897e2ecd1b6187167b57444394d1e64e8f63e5db011d77c80b5fe6df2f67fecffe82f861fb761190c6b3248346cd9f5b5c SHA512 e735e2ae63aa410a56c79bef0bec7196393bb8f52d8521001d298b6290a75662f7262b6cd3c3238eeaf33263036cc6dabf8435ebd2fd1c98481cea524d0382ed
+DIST wstools-0.4.5.tar.gz 201047 BLAKE2B 34c8d2c52ce9d1d67749ef6d0e1d5684a60718ef613688466d0992306f446b153d681b802fb142d1594bccaf37390495fb59e765f662e7550432d8866e038110 SHA512 24779bc2c2f3e32a515bc5690038e3f8e487fd45c1b7822d587e1bfd0bda660b837e3d5cbf8248459e06d7606e6d1c404dcee4de35b1f0d353bd5213e197d83a
+EBUILD wstools-0.4.3.ebuild 593 BLAKE2B 98e5d6f79a1a2425d4ce2764f9e1739510d15f9bf8849516bb4b5278a783fc442b868911efbd56f353f9b80de727cbcd669f8280963a3f0e2454d602fb57c0e0 SHA512 046cff4817e5440376ec2f47c1be6191e63b5fb4e7dde9ce26d232b55f2070932f77cc493678cd9da6d5e8351970775cbfd175451d5d36686b9cd6709c11affe
+EBUILD wstools-0.4.5-r1.ebuild 805 BLAKE2B 67cd12ae99991604a858518f2deefd9c597a2f9b8937f41f9a4fd0ac9efccc6115031de153f63767db193042447d91339c3a1d4c9ef7b6987d707f6b12aec1a0 SHA512 e3374883b220e202e7290d67124bbffa478ecfe7377eaf7433c9e53c67f3382636e024dd8af2899fa52425838b31a4bcead6f1fdf44fa1bbf8fe207958b62192
+MISC metadata.xml 376 BLAKE2B 4bee67bc37a09d4b34b1f67902a820f63563f87d9771eb462eb7f098955806e025196082a7e6c118e5ab0638c7ee70d1a63c8183f607d1ff9a26f1b0c16d5206 SHA512 fe2f379a3d41b128b1c817d4e56fe92b72541bcdfff4e40e05da8a661ab30b5eb623421ce6ec366cdb8431c924f6132a9d15982f1182f6a1f4c71f8301d954b8
diff --git a/dev-python/wstools/files/wstools-0.4.5-setup.patch b/dev-python/wstools/files/wstools-0.4.5-setup.patch
new file mode 100644
index 000000000000..9de7c159c972
--- /dev/null
+++ b/dev-python/wstools/files/wstools-0.4.5-setup.patch
@@ -0,0 +1,46 @@
+Avoid pulling in a lot of unnecessary test and setup deps.
+
+--- wstools-0.4.5/setup.py
++++ wstools-0.4.5/setup.py
+@@ -9,7 +9,7 @@
+
+ from setuptools import setup, find_packages, Command
+ from setuptools.command.test import test as TestCommand
+-from pip.req import parse_requirements
++#from pip.req import parse_requirements
+
+ NAME = "wstools"
+ url = "https://github.com/pycontribs/wstools.git"
+@@ -55,13 +55,13 @@
+
+ def run_tests(self):
+ # before running tests we need to run autopep8
+- try:
+- subprocess.check_call(
+- "python -m autopep8 -r --in-place wstools/ tests/",
+- shell=True)
+- except subprocess.CalledProcessError:
+- logging.getLogger().warn('autopep8 is not installed so '
+- 'it will not be run')
++ # try:
++ # subprocess.check_call(
++ # "python -m autopep8 -r --in-place wstools/ tests/",
++ # shell=True)
++ # except subprocess.CalledProcessError:
++ # logging.getLogger().warn('autopep8 is not installed so '
++ # 'it will not be run')
+ # import here, cause outside the eggs aren't loaded
+ import pytest # noqa
+ errno = pytest.main(self.pytest_args)
+@@ -136,9 +136,9 @@
+ cmdclass={'test': PyTest, 'release': Release, 'prerelease': PreRelease},
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
+- tests_require=get_requirements(base_path, 'requirements-dev.txt'),
++ #tests_require=get_requirements(base_path, 'requirements-dev.txt'),
+ setup_requires=['setuptools'],
+- install_requires=get_requirements(base_path, 'requirements.txt'),
++ install_requires=['six'],
+
+ license='BSD',
+ description="WSDL parsing services package for Web Services for Python. see" + url,
diff --git a/dev-python/wstools/metadata.xml b/dev-python/wstools/metadata.xml
new file mode 100644
index 000000000000..a09270e1fdbf
--- /dev/null
+++ b/dev-python/wstools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">wstools</remote-id>
+ <remote-id type="github">kiorky/wstools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wstools/wstools-0.4.3.ebuild b/dev-python/wstools/wstools-0.4.3.ebuild
new file mode 100644
index 000000000000..5ac5a62e06dc
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.org/project/wstools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/wstools/wstools-0.4.5-r1.ebuild b/dev-python/wstools/wstools-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..9cd40cc8a03a
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.org/project/wstools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_test() {
+ esetup.py test
+}