summaryrefslogtreecommitdiff
path: root/dev-python/wsproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/wsproto
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest2
-rw-r--r--dev-python/wsproto/wsproto-1.0.0.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index d5f870fc1c6d..74df7b017ac5 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1,3 +1,5 @@
DIST wsproto-0.15.0.tar.gz 51765 BLAKE2B 6eae2d2ceeb2d1e870c1ca70db22708fc2e5d10aac6b1d1a44ab00f4b31e18f21fd324c7e8c95e28769f4642601b775dc687eb28b419c5698ed68e617d054599 SHA512 c9666ec65374181da762f460f0c394a5bb599f8a0666989fb2d53e5e8822f5ebdd28eae3098e115d5bbacf6d6e1dd33a9cfeb808d569e1a01025eefaff18c531
+DIST wsproto-1.0.0.tar.gz 53423 BLAKE2B b4cc8c1ef0ccf324821b893b57fc86ab744c639dd07604618485004ef56ca105b5515e1f34a08ccc93de941b1a93eb76ef0d1946f11e05f80d40b98bfe7e4c56 SHA512 36f8c4eebf84bfe869f7124330898d22416b423f47396f2e3f72069e14f1763514e1df700c3e8ee81467cf973197e10143e088978d0688930fa98518af8773fb
EBUILD wsproto-0.15.0.ebuild 507 BLAKE2B a010d403ef7e818dc7577d45898ed3ccba0879182f935c1cab9f55549ad9721413c7828f769562bb0f52dbe5c74a6822980b3b5d329acf5e9859f8046f75d6f3 SHA512 5b57c2fe1a79e68e245e58415071cc73cad18a8124b72d58af71307d3633d7aa1fc90f7f0e0eb6076fc97307ee2b5e4f5e0c3a1b36d5b0a7d56fe5f5d8c871d9
+EBUILD wsproto-1.0.0.ebuild 507 BLAKE2B 58fdd103e0c42b3d7d25477c21f74098ee97f64182301189a3b44230770485404fd42d340ab98c56c982b718a3611f40586a3e1a151ba97fce61c3934daed3fe SHA512 23ca8a584fa832aa7680f5a2f147ed16e1251675bd09f4ca3945c9b6008100e5b9bbc9c4d195d6f540bf99bae04294c5b8aff0341b3b136d2782d439a2c70320
MISC metadata.xml 449 BLAKE2B 20905c7dcbfa8e649ec28d7825903e62987d2c5a77c2e66b21ee8493a9a7bd1294fe4cf89db71497a6580ec1f60aefff7406c0179b258f98db9a6e807d4f0883 SHA512 5652a88da35965492588df16a4b4d17318174284941e61dffa4a618820243ce6795fe566beb7c27a2d39ba56de776e71b49782e7294c7d43b4d48ce67466cc7c
diff --git a/dev-python/wsproto/wsproto-1.0.0.ebuild b/dev-python/wsproto/wsproto-1.0.0.ebuild
new file mode 100644
index 000000000000..642751d07b50
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/h11-0.9[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest