summaryrefslogtreecommitdiff
path: root/dev-python/wsproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-python/wsproto
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest2
-rw-r--r--dev-python/wsproto/wsproto-0.12.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index e70ad1eee00a..d8f62fd62398 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1,3 +1,5 @@
DIST wsproto-0.11.0.tar.gz 41179 BLAKE2B 72486adde659e96910bcc56efe5f3ddd71d962e2844e332eabea2a0cbe5574678be85d330fdd54f951f679dfe5b1c185641a30169cc6cd9ac6c4ed066c6a3533 SHA512 583e030dc88971b3733e5e84e5fbaa70d6043d01485cabbbf45470baa31e4f511aea55e108132fc298aeae0031542af7bdd22b7ae25b11832179025a2fde4bdd
+DIST wsproto-0.12.0.tar.gz 45252 BLAKE2B 1be690faba6665b11e2e1c1725935addb132d7008f0ae81e7d5c383a152a5d79389287b3c152cb380e0bdfc97a3438e2a48b62f3c8acf6b501427bc617225ec0 SHA512 159b7f67eff60c2514cfca17036d95017109fe251def6cec132998ac82a037484e3e248d4335539fd03491f56c491a7cf51582aa3f74a44d7d150220a875b18d
EBUILD wsproto-0.11.0.ebuild 673 BLAKE2B ef3472151357d0b5208a860e0e110ee44a097ee2890879b392ff4868c5e193e5ba4d0d40d1313dc9c327efa44143b7d1b7a0f0dfe829d6d3070c2af4588bba51 SHA512 a2ea337eca93dcf61bfd487baf28d9723d28b7eb539355f476a322dc9a4b94565c3e05be7862eb7403ac6dd5685968ccd5cf4624540fe61f5197f2ebf92c1eb4
+EBUILD wsproto-0.12.0.ebuild 711 BLAKE2B a205ffff33b852bece8d9d7ac18aa4eef13408efa33b26c41006cad0150a65d30bbe6d3673583e93119848f3c5c712625574981e7c1b4a8cc714b1d3281d0fa0 SHA512 2988768b1429000215a81649898cec4eb0ba7bf047eff28cce4153d44b8f9fddc3bbca1186bcdbd95eb2633f20913418fef4f50d451c1fd967aaac7e8ad735db
MISC metadata.xml 589 BLAKE2B cd779642e22d2843565d087f42dee8bc89abc872632f9a3accb251ba89498d7f4d7c494adf83db613ee06591a7a48b40584b4f3ff23f1cf900d6763364e3b843 SHA512 fd6b82b6ef0367af0227bafab043b9a02e84c61a39435d3b93e2b4c492d247ee121a5985510427ded8339db68f1471c18928b2c3fd12f87d72f72320c1d6d854
diff --git a/dev-python/wsproto/wsproto-0.12.0.ebuild b/dev-python/wsproto/wsproto-0.12.0.ebuild
new file mode 100644
index 000000000000..98cb9d8b563b
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ =dev-python/h11-0.8*[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Testing failed"
+}