summaryrefslogtreecommitdiff
path: root/dev-python/wsproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/wsproto
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest3
-rw-r--r--dev-python/wsproto/metadata.xml17
-rw-r--r--dev-python/wsproto/wsproto-0.11.0.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
new file mode 100644
index 000000000000..e70ad1eee00a
--- /dev/null
+++ b/dev-python/wsproto/Manifest
@@ -0,0 +1,3 @@
+DIST wsproto-0.11.0.tar.gz 41179 BLAKE2B 72486adde659e96910bcc56efe5f3ddd71d962e2844e332eabea2a0cbe5574678be85d330fdd54f951f679dfe5b1c185641a30169cc6cd9ac6c4ed066c6a3533 SHA512 583e030dc88971b3733e5e84e5fbaa70d6043d01485cabbbf45470baa31e4f511aea55e108132fc298aeae0031542af7bdd22b7ae25b11832179025a2fde4bdd
+EBUILD wsproto-0.11.0.ebuild 673 BLAKE2B ef3472151357d0b5208a860e0e110ee44a097ee2890879b392ff4868c5e193e5ba4d0d40d1313dc9c327efa44143b7d1b7a0f0dfe829d6d3070c2af4588bba51 SHA512 a2ea337eca93dcf61bfd487baf28d9723d28b7eb539355f476a322dc9a4b94565c3e05be7862eb7403ac6dd5685968ccd5cf4624540fe61f5197f2ebf92c1eb4
+MISC metadata.xml 589 BLAKE2B cd779642e22d2843565d087f42dee8bc89abc872632f9a3accb251ba89498d7f4d7c494adf83db613ee06591a7a48b40584b4f3ff23f1cf900d6763364e3b843 SHA512 fd6b82b6ef0367af0227bafab043b9a02e84c61a39435d3b93e2b4c492d247ee121a5985510427ded8339db68f1471c18928b2c3fd12f87d72f72320c1d6d854
diff --git a/dev-python/wsproto/metadata.xml b/dev-python/wsproto/metadata.xml
new file mode 100644
index 000000000000..67543673df39
--- /dev/null
+++ b/dev-python/wsproto/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>oleksandr.trotsenko@gmail.com</email>
+ <name>Oleksandr Trotsenko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-hyper/wsproto</remote-id>
+ <doc>https://wsproto.readthedocs.io/en/latest/</doc>
+ <bugs-to>https://github.com/python-hyper/wsproto/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wsproto/wsproto-0.11.0.ebuild b/dev-python/wsproto/wsproto-0.11.0.ebuild
new file mode 100644
index 000000000000..6e936e5de835
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ =dev-python/h11-0.7*[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Testing failed"
+}