summaryrefslogtreecommitdiff
path: root/dev-python/wsproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/wsproto
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest2
-rw-r--r--dev-python/wsproto/wsproto-0.15.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index 8e6f51634e82..0b9a32dd41db 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1,3 +1,5 @@
DIST wsproto-0.12.0.tar.gz 45252 BLAKE2B 1be690faba6665b11e2e1c1725935addb132d7008f0ae81e7d5c383a152a5d79389287b3c152cb380e0bdfc97a3438e2a48b62f3c8acf6b501427bc617225ec0 SHA512 159b7f67eff60c2514cfca17036d95017109fe251def6cec132998ac82a037484e3e248d4335539fd03491f56c491a7cf51582aa3f74a44d7d150220a875b18d
+DIST wsproto-0.15.0.tar.gz 51765 BLAKE2B 6eae2d2ceeb2d1e870c1ca70db22708fc2e5d10aac6b1d1a44ab00f4b31e18f21fd324c7e8c95e28769f4642601b775dc687eb28b419c5698ed68e617d054599 SHA512 c9666ec65374181da762f460f0c394a5bb599f8a0666989fb2d53e5e8822f5ebdd28eae3098e115d5bbacf6d6e1dd33a9cfeb808d569e1a01025eefaff18c531
EBUILD wsproto-0.12.0.ebuild 685 BLAKE2B c520480ba202df89ab2999f78e8e06e1c12b61768ef416080d907ac583dcfedc841001dcb0f7719d6ff89f698d3806d35c4f40d6f30dd9ff8943043a79aacfc8 SHA512 101806c808893e9c356aed373e0a838ceefe2415fa61061334f4b636563e37de682006a35d20ed723eacb26f543e95a913bb7ee912b5cd9ea204ce9044b90748
+EBUILD wsproto-0.15.0.ebuild 685 BLAKE2B 6c09e174a3236b9e18c0e306123b561851a42f85c00d54e9d66374dc55ef972abab7b8e562d85b5ddd1de14f9bcdee04acb9f1220e1b9ec3e1ab8f60ac3e386a SHA512 b2d5a5fad27b1d487fe35a531759ac1e4be93b76c5539fe9ea1a7e9e91fa78936a341551cd3d4d0d56fa04bf173469772325707b0de851cb7e4ffdf6043f3041
MISC metadata.xml 589 BLAKE2B cd779642e22d2843565d087f42dee8bc89abc872632f9a3accb251ba89498d7f4d7c494adf83db613ee06591a7a48b40584b4f3ff23f1cf900d6763364e3b843 SHA512 fd6b82b6ef0367af0227bafab043b9a02e84c61a39435d3b93e2b4c492d247ee121a5985510427ded8339db68f1471c18928b2c3fd12f87d72f72320c1d6d854
diff --git a/dev-python/wsproto/wsproto-0.15.0.ebuild b/dev-python/wsproto/wsproto-0.15.0.ebuild
new file mode 100644
index 000000000000..e6b15a59a3ea
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-python/h11-0.8*[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Testing failed"
+}