summaryrefslogtreecommitdiff
path: root/dev-python/wsgiproxy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wsgiproxy2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest5
-rw-r--r--dev-python/wsgiproxy2/metadata.xml11
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild50
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild50
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
new file mode 100644
index 000000000000..8c9e14411592
--- /dev/null
+++ b/dev-python/wsgiproxy2/Manifest
@@ -0,0 +1,5 @@
+DIST WSGIProxy2-0.4.2.zip 18817 BLAKE2B 90334926b726024c1a16b066d11cfe579ad80515861811766753aa772fa97e521466bce0a08c028a965e51ec40b977feb1f4b59aa6c023ca6a431deb63668ed5 SHA512 3dd750263485ceb644373d8ea9692c9a46126a1ed7cd640feba7d42b0fe618e290dcae2f76dc83be77de34211ac473f5a1496a8309e3fcc64982e9642af786fb
+DIST WSGIProxy2-0.4.4.tar.gz 16475 BLAKE2B 8cc91e8364204a03fb8f80abb926e69112c2224b595c695d25e2fa54553fe9c82e3420f68b58f266d04450dd49a6dbf9257c190da8645dfeee976ae101fc708b SHA512 6ae9fca65fe80f52924f42b26b447631e8c278f517ababc23d26e5f8598d6d9b7975197ec74faf64f2e051824366ac14c5db5727a014a187c70a1b4604105b42
+EBUILD wsgiproxy2-0.4.2.ebuild 1301 BLAKE2B 0d508bec0cc43df25bdc9cc79846b7d0ae679b4051aadbca7b2ec2d2b4cdd256876da52982d262d88fc49bf2f9d31e7c75a4eb3aa0afb0a84a35486ba8f7459b SHA512 ad96bbb9a28f3d0e4e3c644e07cc90ea8702bd14383e2bf8bc0617980c11d888cc53a94fdea41e9feaa0ba19869ce4a13424106f9756bd1b0dd992e0960fc327
+EBUILD wsgiproxy2-0.4.4.ebuild 1312 BLAKE2B 30644a4f92e238778c9839c1b4f45938dc170a9aa09e161aab069d9930e0eb2fc827e15f88e7db1edde1d79c7c601c2e6e4fbe3faeb29460c9987cdc3959725f SHA512 522aa657376778704f1358e9aca55d692d4fec6d9cd7a3abf3a84c298ebef3a77b66147646edf844e737b07b5c6dd1fee71921dee3601f64c92a947a8e828bc1
+MISC metadata.xml 313 BLAKE2B 45cd2545e5d5b03206c8c3f2db35c0a95ce08f6c29503c19deee7ebc90f578a8a68bc9ca98a504661d09866ccc0217067643efb84e99cda9d1678231ce01a79e SHA512 147915d551dc542cb68d4cab97a3b187ef698dc450cb730c80eec846e4d4debc954b68d04f76e1df835fcc4d179d705ee95379b38c7d39d0f1ffce809941a7c4
diff --git a/dev-python/wsgiproxy2/metadata.xml b/dev-python/wsgiproxy2/metadata.xml
new file mode 100644
index 000000000000..810c0e4c3120
--- /dev/null
+++ b/dev-python/wsgiproxy2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">WSGIProxy2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
new file mode 100644
index 000000000000..45b230044208
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc64 ~s390 ~sh sparc x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/restkit[$(python_gen_usedep python2_7)] )"
+# Tests needing restkit are skipped under py3
+# Testing also revealed the suite needs latest webtest
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild
new file mode 100644
index 000000000000..bec0dd5b9907
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/restkit[$(python_gen_usedep python2_7)] )"
+# Tests needing restkit are skipped under py3
+# Testing also revealed the suite needs latest webtest
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}