summaryrefslogtreecommitdiff
path: root/dev-python/wsgiproxy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/wsgiproxy2
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest1
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index 8c9e14411592..2c7ab8a7d290 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,5 +1,6 @@
DIST WSGIProxy2-0.4.2.zip 18817 BLAKE2B 90334926b726024c1a16b066d11cfe579ad80515861811766753aa772fa97e521466bce0a08c028a965e51ec40b977feb1f4b59aa6c023ca6a431deb63668ed5 SHA512 3dd750263485ceb644373d8ea9692c9a46126a1ed7cd640feba7d42b0fe618e290dcae2f76dc83be77de34211ac473f5a1496a8309e3fcc64982e9642af786fb
DIST WSGIProxy2-0.4.4.tar.gz 16475 BLAKE2B 8cc91e8364204a03fb8f80abb926e69112c2224b595c695d25e2fa54553fe9c82e3420f68b58f266d04450dd49a6dbf9257c190da8645dfeee976ae101fc708b SHA512 6ae9fca65fe80f52924f42b26b447631e8c278f517ababc23d26e5f8598d6d9b7975197ec74faf64f2e051824366ac14c5db5727a014a187c70a1b4604105b42
EBUILD wsgiproxy2-0.4.2.ebuild 1301 BLAKE2B 0d508bec0cc43df25bdc9cc79846b7d0ae679b4051aadbca7b2ec2d2b4cdd256876da52982d262d88fc49bf2f9d31e7c75a4eb3aa0afb0a84a35486ba8f7459b SHA512 ad96bbb9a28f3d0e4e3c644e07cc90ea8702bd14383e2bf8bc0617980c11d888cc53a94fdea41e9feaa0ba19869ce4a13424106f9756bd1b0dd992e0960fc327
+EBUILD wsgiproxy2-0.4.4-r1.ebuild 1311 BLAKE2B c5396a4a1329201da256cd167959aa440cd7acc8370eb3415b53aaf06318bdbbf37ad62097d746e1c89491846e9ca7b3767946c3b4df989e177aeb7489223f02 SHA512 aa37ca4f2508f90afee59d5b4a46355db9fcb30e214426bf6b024eef651e19b11a667dd86436365fc3d28c91be3ed07c1d5d590c6bdb9e41793b522941986a54
EBUILD wsgiproxy2-0.4.4.ebuild 1312 BLAKE2B 30644a4f92e238778c9839c1b4f45938dc170a9aa09e161aab069d9930e0eb2fc827e15f88e7db1edde1d79c7c601c2e6e4fbe3faeb29460c9987cdc3959725f SHA512 522aa657376778704f1358e9aca55d692d4fec6d9cd7a3abf3a84c298ebef3a77b66147646edf844e737b07b5c6dd1fee71921dee3601f64c92a947a8e828bc1
MISC metadata.xml 313 BLAKE2B 45cd2545e5d5b03206c8c3f2db35c0a95ce08f6c29503c19deee7ebc90f578a8a68bc9ca98a504661d09866ccc0217067643efb84e99cda9d1678231ce01a79e SHA512 147915d551dc542cb68d4cab97a3b187ef698dc450cb730c80eec846e4d4debc954b68d04f76e1df835fcc4d179d705ee95379b38c7d39d0f1ffce809941a7c4
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..3fa947ce702a
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/restkit[$(python_gen_usedep python2_7)] )"
+# Tests needing restkit are skipped under py3
+# Testing also revealed the suite needs latest webtest
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}