summaryrefslogtreecommitdiff
path: root/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/ws4py/ws4py-0.5.1-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/ws4py/ws4py-0.5.1-r1.ebuild')
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
index 21de5cde42da..8fa2990a4f6a 100644
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
@@ -10,13 +10,16 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)?"
+MY_PN="WebSocket-for-Python"
+
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+ EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
fi
DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"