summaryrefslogtreecommitdiff
path: root/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/ws4py/ws4py-0.5.1-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/ws4py/ws4py-0.5.1-r1.ebuild')
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
index 66d94c727f00..94d185d86706 100644
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# We could depend on dev-python/cherrypy when USE=server, but
@@ -7,12 +7,14 @@
# pypy is viable but better with a cutdown set of deps
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="threads(+)?"
MY_PN="WebSocket-for-Python"
inherit distutils-r1
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
@@ -42,11 +44,13 @@ DEPEND="test? (
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch
+)
python_test() {
# testsuite displays an issue with mock under py3 but is non fatal
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
}
python_install() {