summaryrefslogtreecommitdiff
path: root/dev-python/wrapt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
commit6147e25e3b1f6ce82b661605708d0b8292c03f47 (patch)
treeb8c60917145c0a076da1e88dd73edfaad594d5a6 /dev-python/wrapt
parent3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (diff)
gentoo auto-resync : 09:11:2023 - 22:33:12
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest2
-rw-r--r--dev-python/wrapt/wrapt-1.16.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index f4bf7f461fa7..33585234e60f 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,5 +1,7 @@
DIST wrapt-1.15.0.gh.tar.gz 137402 BLAKE2B 8c4764251a89f7795fef71dd71d9c36611d896d2e2791a5e7ce4f665f7b477e683f21aa05251a6ceb96644221a7ff9b01dfe98a7f4d278987dedc17ead39b343 SHA512 6be3fc6380e6bb11a26e35fb093ca54d2e851ab384682f6b1201599980c0429c1e2f23089540b66dd80985baaaf3fb93ce29034758e062e2cfb2f52e3b362779
+DIST wrapt-1.16.0.gh.tar.gz 138520 BLAKE2B 6317f2fa58aaa017b510f60fb20e8b3bc4721977806f4b8e7a3f316bfa4da2a8d24156f8ab670d96f5bab6fcc29437d5d18c28ce91618f5a7093cc85d6c5b578 SHA512 65bdda3b6580748ceb720e8fc1a6b05832a355d541aa650bc87052f3aa8793d03d29a080b79eceb16392e297aed8f11a283e36f5f40a0db614b409b1dc2b6c9c
DIST wrapt-1.16.0rc2.gh.tar.gz 138531 BLAKE2B fc6c573a80ab5a5f82b3e0dc60ecce34642361982b00d4066d84eb186cc2dc2542769205674f74370aff98b252acb65e7013f181c75da3e7389d3bdfe1ff6971 SHA512 f6b6a2a34c6f5c285e08411b2fca2464e21028776595e821e09cfc45da9519b88911fa74d47952de365a7625322672d025fd66be1393238ff776dd6b84cd8aa2
EBUILD wrapt-1.15.0.ebuild 1149 BLAKE2B 5c97192a67030beed9bb7e542ce02828e4e992136aead43430df8409f692322ab21e51f509719e2b807621bb7b1d194aa848ac29f17e64616c1811ed8efddc7d SHA512 acb22a0c6e0791dab7e6292bbb0872acad9db04bbde76ff6195a7c23c9f0e6b2f2ffc97285d5afc600c8cd62b2f6c5302186424bd80d809fe2f92b74ab295445
+EBUILD wrapt-1.16.0.ebuild 985 BLAKE2B daae4e2a2b7dff8efccd212a08f16c6da8e0cddc117d43b4886d5d2db6c98338eb4ddd2d9b31044b9dee5d0958b56f33d94f20bb93bfe8096307bf835fc9c426 SHA512 5ac7ffcb2beb4f01edc3e476376fe033f35d9a93d8fcad993ff970c433ce0e48ffd075cae3761d3197128c68c44910b678ae43e4aa2ed1e36272833531536d83
EBUILD wrapt-1.16.0_rc2.ebuild 985 BLAKE2B daae4e2a2b7dff8efccd212a08f16c6da8e0cddc117d43b4886d5d2db6c98338eb4ddd2d9b31044b9dee5d0958b56f33d94f20bb93bfe8096307bf835fc9c426 SHA512 5ac7ffcb2beb4f01edc3e476376fe033f35d9a93d8fcad993ff970c433ce0e48ffd075cae3761d3197128c68c44910b678ae43e4aa2ed1e36272833531536d83
MISC metadata.xml 515 BLAKE2B 9a7eb633f7a52c3bb378854a89d8b529adfb09f4db96502875da844c4d256aa1ca2346831be3f7949894045d9185df284a7b50c142a22b1340676d079913abf6 SHA512 f260a2482e32147b1a052b949f1b438efcb406b52caad79951b60cd79c330dacc5c612269b80c730c489a9b2896c4d91572796409bbceabc36a83c056522cac2
diff --git a/dev-python/wrapt/wrapt-1.16.0.ebuild b/dev-python/wrapt/wrapt-1.16.0.ebuild
new file mode 100644
index 000000000000..2941453acf76
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.16.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=$(usex native-extensions true false)
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}