summaryrefslogtreecommitdiff
path: root/dev-python/wrapt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/wrapt
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest2
-rw-r--r--dev-python/wrapt/wrapt-1.13.2.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 71884df1cc4f..685aa491498a 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,6 +1,8 @@
AUX wrapt-1.12.1-py39.patch 8250 BLAKE2B d3f40b0ef14dc61a12b4e386d1b14b5f5d7f944ea991c7efb70c535b5f77c489feb31f9b162c9aa6fb68236bd0775ceed6c6582247ca0aacbb79255c90b10d57 SHA512 e157e40e720a173762ca227a1daa0acc7fc437f632943c5b5158cb776b32457d592571ff7dadc4f0069b5ace9cb1fd2ebb51807d78d62ca94d8148a4d5be48aa
DIST wrapt-1.12.1.tar.gz 126750 BLAKE2B 92aba2d400aa626445be68fdda2831132e1c341a2f20065b3d7071a2ebc174cb9de7e6a20a8375360cf7df181881fd20b7b2f70dbfdf533e8823982eeaa722f5 SHA512 33e964cb3aa2437bc7d084a98f622f7c5c8c719d97806796ae0317d35130bdb2679a9dd87be7077e2cae1eb32b65d152349fa7cc138cb392d5999cbfdcecc9ac
DIST wrapt-1.13.1.tar.gz 130138 BLAKE2B bc9a0238a4e16f36e83a6fd81e94d5a257e27e0d5864dc98ba4036f16c3cd92b971e9eddf8193afd13b5afe82ac4f83d50e66f8bedfcd0068ce53f162f4f7ac5 SHA512 a5d7d9013e975261608563fc86b92dd9d455b9efe5f5a79800d317438317f86d59b5678cd4c053832aad2e35dfc08d75b16ed456564cfcbb6541a12a1741352f
+DIST wrapt-1.13.2.tar.gz 130624 BLAKE2B 7ad74653208042326630ae4464494fcdd5299b35a42d495a16a3cbd68bb60fe5ea17f3e95eac85d98142fe339a593a8cda7e3182ce2a6e96f6ba2bb204a1fc46 SHA512 14648465745af7972ffd449783a24a4b5bf8187cbee517d3427825409bd5d073e3153a0c61f5583b84fc6ca2c48479ebf112977ce340369019a617559d09dfc0
EBUILD wrapt-1.12.1.ebuild 765 BLAKE2B 54e2d2d3ce53c7c234f48b305bcfd1c0b1c2a4ea00697816871580dc5347f428af4729ba5f7c280e31420ea88221a640430b8e98472ebf2ab85da2ed882e6253 SHA512 0ec5d5a96394877bc7a29b7feedf13a203d7d0c8282d3f452c70a9026234f6888187756232a98e94bb90c459c2d9c90de9000722bb692fa70e826bea8518d640
EBUILD wrapt-1.13.1.ebuild 700 BLAKE2B 57f46f61c3f869b7e7cbb83447db0e9903079019f44ebf34144720584703843a43b9c5fb9f244e5b604daad6673ff9d3a405f7814eb51a1b30fbe4f71d394efb SHA512 aaed5b5ba473d52598f08c83744da901f98220058c7312943190b5792690e93e4fba44abc1543fc906df0dc6c7ffd7354364338c6740f2f09b979d00a178fd65
+EBUILD wrapt-1.13.2.ebuild 700 BLAKE2B 57f46f61c3f869b7e7cbb83447db0e9903079019f44ebf34144720584703843a43b9c5fb9f244e5b604daad6673ff9d3a405f7814eb51a1b30fbe4f71d394efb SHA512 aaed5b5ba473d52598f08c83744da901f98220058c7312943190b5792690e93e4fba44abc1543fc906df0dc6c7ffd7354364338c6740f2f09b979d00a178fd65
MISC metadata.xml 370 BLAKE2B 251d8c90cd2a0a1b9fbc714b624c7113e9791f268130211160655f4e4e32aadaddaf98a95bb6d9fff5a5df128da9d551b1281a28e4bd7fa6e3c9db7d35b10829 SHA512 31b369317f4a44d593d9fb72bcb9fcb792809323862866da7c3464ca2282e29a65cd353909c05782b85b162cff363b0ad8ea4750d89c942d442034b9a6eb7dba
diff --git a/dev-python/wrapt/wrapt-1.13.2.ebuild b/dev-python/wrapt/wrapt-1.13.2.ebuild
new file mode 100644
index 000000000000..01eb043f35e0
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.13.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}