summaryrefslogtreecommitdiff
path: root/dev-python/whisper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/whisper
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest4
-rw-r--r--dev-python/whisper/metadata.xml2
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild33
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index a2794de32209..89b4ea2e82af 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1,3 +1,5 @@
DIST whisper-1.1.5.tar.gz 38104 BLAKE2B ab36c91c00dd8e8e26b24c0c2967c661f0bd69f3dcb0e52763f6527a233f656a984c738be720c0b5f2d27fff08daa164db87f0ab693d360bd0c087cf6a408340 SHA512 dee42adf1824c876cf15e9e55101d90d08889fd6e267a89c18fdb4a7d4c5a3a0d4f6f24bb0fdeb974fd194046c17e00f71033ddb72c74c4d4ded0a937e82c8a9
+DIST whisper-1.1.7.tar.gz 38289 BLAKE2B 05c5ed972c6dbe8ecc29731d206a44e4db2605aa1270d0eba63c90390062f3cee81a6076a571e6b18cc54f8b1a0ffbc9800c91e9aa7cf3cab862d7e6bb8217c0 SHA512 2dc4f15a91b518495da120af4ad2af4b5f81d04fae6028ca1d7505046b93082a9294452a703c8de87dc89629c35dca0809c4ee7c0df1a7a6bd5ec527f3126df2
EBUILD whisper-1.1.5.ebuild 752 BLAKE2B 0ff5a4c2485a9ba9076780a7789f7b10fb7e0e416bc7e1eecdefde2b61e3432c06116751ed582cefa9fd0ad85e070c976a5d75fe22bcb2a3148341c04300dd09 SHA512 118b924305d7010728c88eacfdbc26b550c36a7f9306a7a9465c66a76c446a466b6fd9767adfe2fc6d5074c8b506b149a1160d840bda62e61d2f5b43d8f22807
-MISC metadata.xml 556 BLAKE2B afcecd89f7f06cef8d991edd5476a6ec0db7753d2d58174ec5a1a955f6023a06d56f0ae933e438bc720b9cf777852df4d223a21557454ee7d6aeef7741f451ee SHA512 7f72e3305aa749df979f180e0d46efd3ce1edfd81e76f5cb8a808d433ee2b19741b756f0e2c7706fce8bf2b4ae9adc336e309d3ed902e3d122fd1617dcd26af0
+EBUILD whisper-1.1.7.ebuild 787 BLAKE2B 1e1b30a2977ff043605926a06ca06b2cd0318460883384494493117ddd3312e4519dca9bcc6ec8f8e60304b43a118d7e7e7bdfd0336eea0cc91c9378a3a96949 SHA512 1abd7b331d5ab764957093616f9adc75f8e912b7d599339e4b94ff308c32f4c960c41109ce87d3c4528e21f2aae30cf3dc07af9a7d5c1ae2f110e0e2e53a5d16
+MISC metadata.xml 679 BLAKE2B 1e917a1f0626077ec990cef9c4973929fe7c1aeb9501caa4e80a5ab7d7599b03d93a2c91dbe5f4afd81b12f41688a4c6894442a18d3c9f5009cd314f77414367 SHA512 d2374c4f0abc36fb04b714ad6edadcbcd992fa70029f74eb3e568f81a11d3dd279db77901d634a8a80ba64dc6852195e88d2e8347a9c79fdb6d13f2290397186
diff --git a/dev-python/whisper/metadata.xml b/dev-python/whisper/metadata.xml
index 5088568e3bec..8ca3f6c7e617 100644
--- a/dev-python/whisper/metadata.xml
+++ b/dev-python/whisper/metadata.xml
@@ -9,9 +9,11 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">whisper</remote-id>
<remote-id type="github">graphite-project/whisper</remote-id>
<bugs-to>https://github.com/graphite-project/whisper/issues</bugs-to>
+ <changelog>https://github.com/graphite-project/graphite-web/blob/master/CHANGELOG.md</changelog>
</upstream>
</pkgmetadata>
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
new file mode 100644
index 000000000000..201d0c86240a
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+#python_test() {
+# py.test || die "tests failed with ${EPYTHON}"
+#}