summaryrefslogtreecommitdiff
path: root/dev-python/whisper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/whisper
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest6
-rw-r--r--dev-python/whisper/whisper-1.1.10.ebuild34
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild21
-rw-r--r--dev-python/whisper/whisper-1.1.8.ebuild24
4 files changed, 36 insertions, 49 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index f512b7e5c221..cda355793297 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1,5 +1,3 @@
-DIST whisper-1.1.7.tar.gz 38289 BLAKE2B 05c5ed972c6dbe8ecc29731d206a44e4db2605aa1270d0eba63c90390062f3cee81a6076a571e6b18cc54f8b1a0ffbc9800c91e9aa7cf3cab862d7e6bb8217c0 SHA512 2dc4f15a91b518495da120af4ad2af4b5f81d04fae6028ca1d7505046b93082a9294452a703c8de87dc89629c35dca0809c4ee7c0df1a7a6bd5ec527f3126df2
-DIST whisper-1.1.8.gh.tar.gz 39117 BLAKE2B 591a3529725f300c6d8bab40444bdd41bcfe3d832893e954295d5387e047e2a639db4235131cd90fdb686395d51afccf30f64a52e194e4cd8e00b86e38f841d6 SHA512 0452c684128a750e30e926aee0cfd6c94f129eeb561246f9e1c66d7cf1f27f139df84f91e935237f89d0b4fac98678108568cfb94c2ab4138480f4db31471ab4
-EBUILD whisper-1.1.7.ebuild 590 BLAKE2B f960bdc65f64aa267d41bd61ef2bb721f0656e3bcb37cc463d8606e59b3a9fbc19bb2c0cd5f10c35a51716bbe9deff3d9daa16c622779f8678ca68eba91a0f6d SHA512 cd7480680c22d7a64c0a80fb9550f0bd3afd1236b9b33790b910eeb635e4bc958ad70aa370a32a2bdd7f6d7d6977add282ddee2b1868019bb67443117a7802a0
-EBUILD whisper-1.1.8.ebuild 608 BLAKE2B 9c03b7315b46c5db44cf13c384c61e226fa1608b1bc9d381b445bbcc3bf343e82c492187a210684c1b3dbbfe1f3fc126b5274fbbcf4ade996405c22fb865aa8a SHA512 a944b6e748575e26243fd9ee0636d9c1979e7404eb19400ce3b8c8d76dba0d4808d9a7f4c476973ee53ef9815b3a83684395e6f6219be073fe888fce314b52ef
+DIST whisper-1.1.10.gh.tar.gz 39459 BLAKE2B 998c4335236ace6b28f11b23fe74d3b618ba2f56939a3e9766e7010eb6b5d9bbdb46de83ba41dd926d3d38e738851133dc9805a4c79bd80dd67897e627147550 SHA512 291d441287ba090157fa01a7feb6985a6e1f057f4dae0f9133e2355e00f5fe219e10de339ecad3438a56b8dec97def14496d85c7a5fc5fc7611771bb3de08de8
+EBUILD whisper-1.1.10.ebuild 629 BLAKE2B 45c3e838266832a96c3db3f04c674a5a6e744b01cb707181985522db46665d8697ece6d017ca558007af8889be834a409ee3f5c5f4cb51d3f21cd271724d6c34 SHA512 dd1edef606060c39bfef4ad175f221eb9df5ccbfe90bc49423c5f7e9e6100e3b5a50fa316921f525172293e1894b3efaacf68202ddeca35f188022978a9e086c
MISC metadata.xml 680 BLAKE2B 070ec3c5c71cea8d95302162acda73a61d7c0fbd195ec4edb8cc34c496be8e89d8254be122dbb2797de2fc5255fcc69a26f308aaf5058088b9df14f06a8e1e95 SHA512 3de2424fa3cf4c2482fc5ce743b37b53cd354424b0c11823918f64be6ab2ff5195794d73a0504a4e119e861d3f5f0f6a0dbb385cf37641e7acbf96812d752702
diff --git a/dev-python/whisper/whisper-1.1.10.ebuild b/dev-python/whisper/whisper-1.1.10.ebuild
new file mode 100644
index 000000000000..7c5e02c4610f
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="
+ https://github.com/graphite-project/whisper/
+ https://pypi.org/project/whisper/
+"
+SRC_URI="
+ https://github.com/graphite-project/whisper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
deleted file mode 100644
index 0b3dd86386f4..000000000000
--- a/dev-python/whisper/whisper-1.1.7.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-inherit distutils-r1
-
-DESCRIPTION="Fixed size round-robin style database"
-HOMEPAGE="https://github.com/graphite-project/whisper"
-# PyPI tarballs don't contain tests
-# https://github.com/graphite-project/whisper/pull/253
-SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
diff --git a/dev-python/whisper/whisper-1.1.8.ebuild b/dev-python/whisper/whisper-1.1.8.ebuild
deleted file mode 100644
index f960a40caf88..000000000000
--- a/dev-python/whisper/whisper-1.1.8.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Fixed size round-robin style database"
-HOMEPAGE="https://github.com/graphite-project/whisper"
-# PyPI tarballs don't contain tests
-# https://github.com/graphite-project/whisper/pull/253
-SRC_URI="
- https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_tests --install pytest