summaryrefslogtreecommitdiff
path: root/dev-python/wheel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wheel
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest7
-rw-r--r--dev-python/wheel/metadata.xml11
-rw-r--r--dev-python/wheel/wheel-0.29.0.ebuild45
-rw-r--r--dev-python/wheel/wheel-0.30.0.ebuild45
-rw-r--r--dev-python/wheel/wheel-0.31.1.ebuild45
5 files changed, 153 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
new file mode 100644
index 000000000000..cf942ae6f67f
--- /dev/null
+++ b/dev-python/wheel/Manifest
@@ -0,0 +1,7 @@
+DIST wheel-0.29.0.tar.gz 54143 BLAKE2B 8f29c81b9b3c8ee419c26f04e09f437a2113716f5096e1b6e21f23e6a7426e58b7ee00c0846cfcd816670bee4dd908ef577e4142fae546d4ea643af2c2612049 SHA512 b72dec3cf71e3d87c611ff41f1381ed7f2c654edb50c808fb4fd0f552bab3572434495bf18c36d2ecc7cb8b355782054d3d6dedd5589ffda15027e72cff24602
+DIST wheel-0.30.0.tar.gz 43087 BLAKE2B 796a57298571a9430094be93f38c679941157679d5a75d7d5da88be4d1f970f5aeb9810bbaaa31c77b71959b3c6eadcd618314ab3fa82b959c592c72b8171c0a SHA512 d39fb683ca2937745b057464ec17f5fab0475c2b1225cc4c84f1b0e8cd61a4bb039730dafdaa687f7b054ce080c4b7acbd3196045db14e015585536fcf498f84
+DIST wheel-0.31.1.tar.gz 38574 BLAKE2B 83684b33d587fe4a9593aa1b45c8e3f9543a97f80767c973f2b796bd23191af489760507fc491e4c471d804cb8c8a969de2e6cc509beeae66e1911650be5d725 SHA512 38854a54722cd8b3ff3b53bc62fc56255b37adac5ffb3fc1b0cb5f252a3cebd84390f3bac0600835c64bbec158337a7a13f0725dda47a659183fd038986cdd75
+EBUILD wheel-0.29.0.ebuild 998 BLAKE2B fe9d6e9b2a16944bc754ba9d9bcfcd471bb4f4d3d5cd3db6c15e575042eba4aee12103b5af9be465396f215152ed8b147c5939d649a72c1637c6cd40577491eb SHA512 387cd792495d26346e4aea329e53ca640c0582f78af2b7a7a5e96d6ec2d7bf4c581ae6deeb12a51d869f69a8e58d764f709b76464003c17e53b1f61088249bd8
+EBUILD wheel-0.30.0.ebuild 1023 BLAKE2B 5a96e4dddb45dbc42c58b484b505683d0653668a20943debae1561faf22aa8e1d98145853e3aa68a1a06e03dda9fc758e3babc4fd7eb65be90f625ce81098377 SHA512 646b30a918659e0b0ea0a0eeb64e17082500620e1b5451618439a109e963025884abd87ea838a5bbd8d530fd4823daa8d94591aea2ff738eb020f8d8ebf59d53
+EBUILD wheel-0.31.1.ebuild 1023 BLAKE2B 3a17fe464465fa368d9c2157e016d237a08b7dcad11ea257adc3e632d0bc7cc401d035a6823f822cd924a15bd9bda64f421b64496fb550e3dfb5363bbc037980 SHA512 0805ef8cd9ce426fb867c018855cec7e6c1f1d2c557b12732203b09c0fd488ce4195c7f34441229fe2509ef427273d791718303b9f7464340703a760463c1817
+MISC metadata.xml 308 BLAKE2B 32390fb7a1a3de815d3a791850d9f96d8092be48cf2ac61f8cebdf132e7d1c5c4cba95bac3edc3f2ebd6a2d9e9437e0c9187f9668ed95c4ddb4ee6072f496d46 SHA512 d5fdaba19a51f826d45ba93cc77a08fd4be563634f51236cec379763f066ed925869a57c94c75a34ed58302619d419f31dcad641d9e85c68d11d72ec53d2d45d
diff --git a/dev-python/wheel/metadata.xml b/dev-python/wheel/metadata.xml
new file mode 100644
index 000000000000..2808e69afc4d
--- /dev/null
+++ b/dev-python/wheel/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">wheel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wheel/wheel-0.29.0.ebuild b/dev-python/wheel/wheel-0.29.0.ebuild
new file mode 100644
index 000000000000..dc9a228b0dd9
--- /dev/null
+++ b/dev-python/wheel/wheel-0.29.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/keyring
+# dev-python/keyrings_alt
+# dev-python/ed25519ll
+# dev-python/pytest[${PYTHON_USEDEP}]
+# )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Signature support" \
+ dev-python/keyring \
+ dev-python/keyrings_alt \
+ dev-python/ed25519ll
+}
diff --git a/dev-python/wheel/wheel-0.30.0.ebuild b/dev-python/wheel/wheel-0.30.0.ebuild
new file mode 100644
index 000000000000..cc90e685010d
--- /dev/null
+++ b/dev-python/wheel/wheel-0.30.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/keyring
+# dev-python/keyrings_alt
+# dev-python/ed25519ll
+# dev-python/pytest[${PYTHON_USEDEP}]
+# )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Signature support" \
+ dev-python/keyring \
+ dev-python/keyrings_alt \
+ dev-python/ed25519ll
+}
diff --git a/dev-python/wheel/wheel-0.31.1.ebuild b/dev-python/wheel/wheel-0.31.1.ebuild
new file mode 100644
index 000000000000..f0aa2dd6026d
--- /dev/null
+++ b/dev-python/wheel/wheel-0.31.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/keyring
+# dev-python/keyrings_alt
+# dev-python/ed25519ll
+# dev-python/pytest[${PYTHON_USEDEP}]
+# )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Signature support" \
+ dev-python/keyring \
+ dev-python/keyrings_alt \
+ dev-python/ed25519ll
+}