summaryrefslogtreecommitdiff
path: root/dev-python/wheel/wheel-0.37.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/wheel/wheel-0.37.1-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/wheel/wheel-0.37.1-r1.ebuild')
-rw-r--r--dev-python/wheel/wheel-0.37.1-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/wheel/wheel-0.37.1-r1.ebuild b/dev-python/wheel/wheel-0.37.1-r1.ebuild
index 214338dbe121..8b1ef52db3b6 100644
--- a/dev-python/wheel/wheel-0.37.1-r1.ebuild
+++ b/dev-python/wheel/wheel-0.37.1-r1.ebuild
@@ -5,24 +5,30 @@
EAPI=7
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
+HOMEPAGE="
+ https://github.com/pypa/wheel/
+ https://pypi.org/project/wheel/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]"
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-python/setuptools[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest