summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
commitcd1445321d1a6609cc7215588a79b2232c8a9bd3 (patch)
treefb9d68dde365101c0774ba4166a38ab3afa0e362 /dev-python/whatthepatch
parentb8ec9071f5d20d8518b02d0077428b2c9f88861b (diff)
gentoo auto-resync : 29:01:2023 - 08:54:36
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest2
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.4.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index 9d27971f585d..94846f7b8ea9 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1,3 +1,5 @@
DIST whatthepatch-1.0.3.tar.gz 28634 BLAKE2B 94c5a074bf30ce81dbad1c8c3830efa726f8526e35da03949abb32803721ed01f3faf4c6bfe098bf679e3990489c19a7ba06c73a86959e4ee59adc2a37d59e3b SHA512 87e3e0aa78f71ad73f1b9663c3b1b53ae700ce82f2a5135717487d2ce8e597e3eeb2a9316b3ac96c27eb25a4a8c1e11658d93e976e882dd9f46cb1057f317211
+DIST whatthepatch-1.0.4.tar.gz 31063 BLAKE2B b3f66ca0783ae147ebf5d47aa155a23cfbc16fc19aaca9812b53b2a292543f64447e31b469645bfeffb8ab1b8a5ea7cebb9ebad5e9815d6a84a3b44068329448 SHA512 89705fa1ad4a797038b8c4cd30c7ca88b5b51474265bc157f45c244b258075cde587c6da16fabfaa2d6b90eee858ccf82c9f01ce8e44412a5eac504f95fb413b
EBUILD whatthepatch-1.0.3.ebuild 488 BLAKE2B b125fd6b94edc93d2e03e3a0d83f493b8064ee1bc34998b2edf35df6fd06c26e6bcf1929c8223ac397fed80432efa7a519f40866decffd0f57b4d67dc1fc0def SHA512 fd13a7f355ad933cae6772a7bd11d10e4d1e9a438bda0212b92ac37302362a34146fecf6133bbb67902491b7257a048c8f955f472b206121f8e0dc7df2d66045
+EBUILD whatthepatch-1.0.4.ebuild 490 BLAKE2B 402f112362c418bf9723b074621e55c9db1db08a75bad5bfaa3c4a745d449cdd0cec4fb4209107ee83cacc5d07981fe6f9c7612dd3c7732dd4a7c7312c3e7609 SHA512 8b5d98898725816a65796379e3ad79b12b3427944a6ea12b24e9d9ae4daa22b4b7d7f5d778d6f898409b9bb95b01587524e26307440fd122fd9ebc38aa88a8e5
MISC metadata.xml 401 BLAKE2B ee370b7f08a16ea4054d5192831a530a9bceac969b2832d6fe058e98dd7558498afbebf4c1f2102979b2f3c252de73c5b11aafcdfed7044a5218144def4f333a SHA512 2a5c7944923e59032c3e75a0a08339ab4b273a346ef855a8ff61c45cc52ecc847db314b0e733876e6d14c3ca42418d9573a26d7f47213958f44a47c6dcbb6c48
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.4.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.4.ebuild
new file mode 100644
index 000000000000..14cb3b738351
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest