summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
commit4828c25c25aacf399de429d381288982fd7e0d0e (patch)
treea265b5f79cf1b578c4e54483be1466f657f4baba /dev-python/whatthepatch
parentf8d671851faf1ca201cec0490ead4642c8987bae (diff)
gentoo auto-resync : 14:11:2022 - 00:49:44
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest2
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.3.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index 7543135bc8a2..b1a137c9f6ee 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1,3 +1,5 @@
DIST whatthepatch-1.0.2.tar.gz 28459 BLAKE2B e24c882fe1ad42f27eeced72d92423d807ac3284bf0045674b78a247a7222bb142d500129b82a32f8fc95934beaa87a378822da2ef80b1d66d98c171b3a15666 SHA512 e77aa6e934f26647b7a060f46eedd8f5984e43b93b7d576cf8d7a930d08e4b3c5c96c79e61e001df405f3f18c07e4296ce79009d9b9e9c721342af9f8560b4cf
+DIST whatthepatch-1.0.3.tar.gz 28634 BLAKE2B 94c5a074bf30ce81dbad1c8c3830efa726f8526e35da03949abb32803721ed01f3faf4c6bfe098bf679e3990489c19a7ba06c73a86959e4ee59adc2a37d59e3b SHA512 87e3e0aa78f71ad73f1b9663c3b1b53ae700ce82f2a5135717487d2ce8e597e3eeb2a9316b3ac96c27eb25a4a8c1e11658d93e976e882dd9f46cb1057f317211
EBUILD whatthepatch-1.0.2.ebuild 444 BLAKE2B 150927293bef46ba8c4457242a19b388fd8a5f845ad8eaff54019eb5471733c3424287232c19f0a916701eeac96da7eb288683ea4882b1d1b30837f5931d7ee4 SHA512 b0332c7f3539df3ee251ab733e23055627ab0b56834eec4b290a0973a41eb659690c1cb27787c108be4724e28e26e930c84ec893ce9d782d54d5b6c38c6161fd
+EBUILD whatthepatch-1.0.3.ebuild 490 BLAKE2B 9fde814411b12ebe3116c9a705fdea89957a9e4d3fc5bb24587d1e18101e2035227eb017bf159424d06da4113e25d060a3d0c90848f80a77615c6554db95d2fe SHA512 be31b43aa9624c5b9e5303cab03e171f9a703ec3601b0e817ffdc65a179bc64b629c748946020e4827f350101e50c96dfd52048277700a7b342efe2a7a7be39e
MISC metadata.xml 401 BLAKE2B ee370b7f08a16ea4054d5192831a530a9bceac969b2832d6fe058e98dd7558498afbebf4c1f2102979b2f3c252de73c5b11aafcdfed7044a5218144def4f333a SHA512 2a5c7944923e59032c3e75a0a08339ab4b273a346ef855a8ff61c45cc52ecc847db314b0e733876e6d14c3ca42418d9573a26d7f47213958f44a47c6dcbb6c48
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.3.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.3.ebuild
new file mode 100644
index 000000000000..832cde2990e5
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest