summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 12:31:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 12:31:21 +0100
commit7e8f29e487b79a183d66ca22f1e54dab5c47a409 (patch)
tree1aaa96a96a9f9ee78350986f9f8cb8b23fcb1c5f /dev-python/werkzeug
parent7a36a65c987a298331a241fb01e229665e4983cd (diff)
gentoo auto-resync : 09:04:2024 - 12:31:21
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/files/werkzeug-3.0.2-pytest-xprocess-1.patch21
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.2-r1.ebuild74
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 5cafc54f72a1..7a9aa4a185c0 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,5 +1,7 @@
+AUX werkzeug-3.0.2-pytest-xprocess-1.patch 864 BLAKE2B ff18777cce9debbb39ae524a54912417a3d3bd46a54b4ba91322f9abe038b47e4091049f4e4ebb9bf5c0e661b0d88bea2d157b840d02d81442a323b222d840d2 SHA512 8208a0b6695d6079b0bf251bba8cf2c3c7fb89a37aadeb74c534e6c61a7455e71fb61ec6a44d2689a311e77d9d00302a7d2dafa449deb7d4e207038bd43ac372
DIST werkzeug-3.0.1.gh.tar.gz 817317 BLAKE2B 670460cf48c8d06196cd34f117758508512d310b740bd188d8ba87779abd62f514c9909e5700b34c37e382925eabe3ffd722b753b76b498aff0dc8ebe1025c8b SHA512 125a5c7680cba726149198802efa90d06c6586daeafcd0960feda637b765356f602df83af7b14996994303c52d32bc6fa044b774f42f0b8991008d1396675033
DIST werkzeug-3.0.2.gh.tar.gz 817516 BLAKE2B 0c3324b6793f2fad77f62fbd0e3b847a73d6348d4a069dd83c852475d9cfa88feb3ab3ff1c4d547622b732de5fc3ba781d776d30f11ec1fae93cafdcfd9077eb SHA512 fdf44d2af517af69632909ae6fd5af327f34778c8f2dc7e606380123941102cc09d593a2036e843036e5abe998d2b2722f97b959eaeffc8de2b71a5b372a1e3e
EBUILD werkzeug-3.0.1.ebuild 1903 BLAKE2B c82f77abe6278f9a4efa589870eff1f477fe39009ac95bc7682cf1e74d2c4afbfcea6cdec5bac6e40f66a2ad1d3c9797cd6f69f3628c09ed384b77704c7afcd3 SHA512 d4166da9662133ecded61fe226c2de6ffca4a01768da3b4cdaf62889ba77ec13823edf2ad445f080ddc9b1f8e21d9a38cf69c8be7b129809eac38709d526f227
+EBUILD werkzeug-3.0.2-r1.ebuild 2030 BLAKE2B d9c4848b0ddd02a4f8d527ebb72391c2d61ed66fcb489d5b09cf2176536cbb81f340039bfd155d40bfeeea634bfb598eaad0c1eb837b49cf9bfc14b3f0bbc318 SHA512 fdbe0048c8afb935961afdf41c6c71d90d901f3c21ac41d07627ffe8582db765a8c32a5b22c13a1c43f9eabb9437aa20ff36e04a83923838380ad9020f434bda
EBUILD werkzeug-3.0.2.ebuild 1974 BLAKE2B cf435f526bcf857be2c408ffecf693fa31ea880a239a0d76d45cae77fbc49b2046c17a23983b9ec1fd80b84dd97586d63299d4eb2bc3ba83bf54eb82daf1f959 SHA512 b399a73f9b9a6d8b050c57be86492fdfb101425fc3af6f6c476bbacbe4aa8be3168c823cde4d2c0619cdbaa0872b9580104a56d798330ec11628ff64ca462b50
MISC metadata.xml 368 BLAKE2B 81932229098620395623f9149ac974f19fae9b65ad09943ee5c5d8d03c1e37e76061291c959fe5f004f531a244b3bb335c2a43dd66949c0be43493e45674d0e3 SHA512 67e5b5fea8052c0723820125271ea031ad984e0fe2af21d2423fc559bdc51dfe1d40f2fa5fe11e6d2b8b32216e716900080b859aad146c079ad2b390dd9844cf
diff --git a/dev-python/werkzeug/files/werkzeug-3.0.2-pytest-xprocess-1.patch b/dev-python/werkzeug/files/werkzeug-3.0.2-pytest-xprocess-1.patch
new file mode 100644
index 000000000000..3993b0847957
--- /dev/null
+++ b/dev-python/werkzeug/files/werkzeug-3.0.2-pytest-xprocess-1.patch
@@ -0,0 +1,21 @@
+diff --git a/tests/conftest.py b/tests/conftest.py
+index b73202cd..905f3f4b 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -107,10 +107,12 @@ def dev_server(xprocess, request, tmp_path):
+ # Unbuffered output so the logs update immediately.
+ env = {**os.environ, "PYTHONPATH": str(tmp_path), "PYTHONUNBUFFERED": "1"}
+
+- @cached_property
+- def pattern(self):
+- client.request("/ensure")
+- return "GET /ensure"
++ def startup_check(self):
++ try:
++ client.request("/ensure")
++ return True
++ except (ConnectionRefusedError, FileNotFoundError):
++ return False
+
+ # Each test that uses the fixture will have a different log.
+ xp_name = f"dev_server-{request.node.name}"
diff --git a/dev-python/werkzeug/werkzeug-3.0.2-r1.ebuild b/dev-python/werkzeug/werkzeug-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..67830a3b7586
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.0.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xprocess-1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pallets/werkzeug/issues/2875
+ "${FILESDIR}/${PN}-3.0.2-pytest-xprocess-1.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # RequestRedirect class started incidentally being tested
+ # with pytest-8, though the test isn't prepared for that
+ # https://github.com/pallets/werkzeug/issues/2845
+ 'tests/test_exceptions.py::test_response_body[RequestRedirect]'
+ )
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}